Gönderen Konu: [Nasıl] Hoparlorler için ALSA derlemesi (ubuntu 8.10,9.04)  (Okunma sayısı 14837 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Sisteminizin Sesinde Sorun Yoksa Sakın Denemeyin!!!!

8.10 intrepid ibex için:

Kendim bunu kullanıyorum çok güzel ve iyi ses veriyor ;)
1.Pulseaudio'yu silmek
en başta gereken bağımlılıkları kuralım:
Kod: [Seç]
% sudo apt-get install alsa-oss
% sudo apt-get install libasound2
% sudo apt-get install libasound2-plugins
% sudo apt-get install sysv-rc-conf

sonra pulseaudio'yu gnome-settings-deamon'dan silelim:
Kod: [Seç]
% gconftool-2 -s -t bool /apps/gnome_settings_daemon/plugins/sound/active false
pulseaudio'yu kapatalım:
Kod: [Seç]
% asoundconf unset-pulseaudio
runlevel'den silelim(overkill)
sayfayı aşağıya indirdiğinizde pulseaudio yazan yerler olacak
oradaki tkleri kaldıralım
Kod: [Seç]
% sudo sysv-rc-conf
2.ALSA ayarları

Kod: [Seç]
% asoundconf list
yazalım, gelen çıktı şöyle * bir şey olacaktır:
Kod: [Seç]
Names of available sound cards:
Intel

ve orada çıkan kartı varsayılan yapınız:
Kod: [Seç]
% asoundconf set-default-card Intel
Ve şimdi sistem>tercihler>ses teki ayarları şu şekilde yapınız



ve restart yapınız şimdilik bir açılış sesiniz olmayacak ama
reset attıktan sonra açılış sesini açabilirsiniz.  ;)

Kaynak: ALSA instead of Pulseaudio
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
9.04 jaunty jackakobe için:

aynı bağımlılıklar:
Kod: [Seç]
% sudo apt-get install alsa-oss
% sudo apt-get install libasound2
% sudo apt-get install libasound2-plugins
% sudo apt-get install sysv-rc-conf

1.Pulseaudio'yu silmek
Kod: [Seç]
$ sudo mv /etc/X11/Xsession.d/70pulseaudio ~/
2.Pulseaudio kullanımını kapatmak
direkt kapatalım(overkill)
Kod: [Seç]
sudo update-rc.d pulseaudio stop 50 2 3 4 5 .
öntanıtımlı ayarlardan kaldıralım:
Kod: [Seç]
asoundconf unset-pulseaudio
asoundconf set-default-card Intel

libao.conf'u alsa'ya çevirelim(ctrl-x ile kaydedin)
Kod: [Seç]
sudo nano /etc/libao.conf
default_driver=alsa

sesteki herşeyi alsaya çevirin

3.ince ayar
Kod: [Seç]
sudo gedit /etc/pulse/client.conforadaki "autospawn = yes" yazısını "autospawn = no" yapın

Kod: [Seç]
sudo gedit /etc/pulse/default.paalttaki yazıları bulun
Kod: [Seç]
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
ve hamen altına bu yazıları ekleyin
Kod: [Seç]
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
ve kaydedin.

Kod: [Seç]
sudo gedit /usr/share/alsa/alsa.confu açın ve ‘/usr/share/alsa/pulse.conf‘ u bulun ve yanına # yerleştirin
böyle * bir şey olacak
Kod: [Seç]
@hooks [
    {
        func load
        files [
#           "/usr/share/alsa/pulse.conf"
            "/usr/share/alsa/bluetooth.conf"
            "/etc/asound.conf"
            "~/.asoundrc"
        ]
        errors false
    }
ve kaydededin

Kod: [Seç]
sudo gedit /etc/mplayer/mplayer.confyazın ve
Kod: [Seç]
# Specify default audio driver ao=pulse,alsa,
Kod: [Seç]
ao=alsaya çevirin
Kod: [Seç]
alsamixeryazın ve sesi istediğiniz ayara getirin

ve reset atın
iyi müzikler  ;D
kaynak: 9.04 Alsa
« Son Düzenleme: 12 Temmuz 2009 - 17:48:10 Gönderen: maxxblade »

« Yanıtla #1 : »
Pek memnun kalmadığım ses meselesi için bir denesem mi acaba? :)
Eline sağlık, her ne kadar dağıtımlar PulseAudio'ya geçişi hızlandırsalar da sanırım Alsa'ya hâlâ iş düşebiliyor.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #2 : »
ben hoparlorler çalışmadığı zaman(ubuntuyu ilk kurduğum zaman)
bulmuştum ve çalışmıştı alsa'yı çok seviyorum  :)

« Yanıtla #3 : »
inşallah benım derdime derman olur

« Yanıtla #4 : »
Bu konu sabitlenebilirmi?

edit:teşekkürler
« Son Düzenleme: 22 Nisan 2009 - 23:57:39 Gönderen: maxxblade »

« Yanıtla #5 : »
bende flashlarda ses yoktu.
Kod: [Seç]
sudo apt-get install flashplugin-nonfree-extrasound bunu kurdum. ses düzeldi sonra bu sayfada olanları yaptım. ses tine gitti. ne yapmam lazim? synapticten flashplugin-nonfree-extrasoundu yeniden kursam sorun olur mu.?

birde benim şimdi 8 sekmede toplam 80 kusur dakikakalık youtube videosu var bu inmiş videoları kurtara bilirmiyim? /temp klasöründen kopyalıp dragon player ile açıyorum ama acayip gürültülü cızırtı var sadece.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 08 Haziran 2009 - 21:07:06
synapticte aratınca çıkmıyor.
Madem ki sen bensin, ben de senim, niceye şu senlik benlik...

« Yanıtla #6 : »
Bir ara buradakileri deneyerek ben de sesten mahrum kalmıştım. Arada bir şeyleri kaçırdığımı da sanmıyorum ama ne yazık ki sadece ALSA ile yola devam edemedim. PulseAudio pek hazzettiğim kıvamda değil şu anda. Özellikle Flash devreye girdiğinde sistemde ilginç problemlere neden olabiliyor. Hani Firefox OSS ile anlaşabilse tamamen geçerim ancak onda da OSS ile sorun var.

Kısacası yaptıklarını geri alıp eski şekilde PulseAudio ile yola devam edebilirsin.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #7 : »
flasha dair ne varsa kaldırdım.  yeniden kurdum. yeniden başlatınca düzeldi ama videoları kurtaramadim:D  ilgilendiğin için teşekkürler.

aşağıdaki *bağlantıda nasıl kaldırılıcağı anlatılmış ;

http://forum.ubuntu-tr.net/index.php/topic,9553.msg118276.html#msg118276
« Son Düzenleme: 08 Haziran 2009 - 23:06:02 Gönderen: ns »
Madem ki sen bensin, ben de senim, niceye şu senlik benlik...

« Yanıtla #8 : »
Teşekkürler tam aradığım şeydi  ;)

« Yanıtla #9 : »
heartsmagicin tavsiyesi üzerine * her şey  geri almaya karar verdim

Alıntı
9.04 jaunty jackakobe için:

aynı bağımlılıklar:
Kod:

% sudo apt-get install alsa-oss
% sudo apt-get install libasound2
% sudo apt-get install libasound2-plugins
% sudo apt-get install sysv-rc-conf


1.Pulseaudio'yu silmek
Kod:

$ sudo mv /etc/X11/Xsession.d/70pulseaudio ~/


2.Pulseaudio kullanımını kapatmak
direkt kapatalım(overkill)
Kod:

sudo update-rc.d pulseaudio stop 50 2 3 4 5 .


öntanıtımlı ayarlardan kaldıralım:
Kod:

asoundconf unset-pulseaudio
asoundconf set-default-card Intel


libao.conf'u alsa'ya çevirelim(ctrl-x ile kaydedin)
Kod:

sudo nano /etc/libao.conf
default_driver=alsa


sesteki herşeyi alsaya çevirin

bu kısmı nasıl geri alabilirim.
« Son Düzenleme: 09 Haziran 2009 - 21:58:41 Gönderen: ns »
Madem ki sen bensin, ben de senim, niceye şu senlik benlik...

« Yanıtla #10 : »
Hangi kısmını? Kabaca ne yaptıusan tam tersini yapacaksın.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #11 : »
işte buraya kadar olanları yaptım burdaki kodların tersini nasil alacağım



Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 09 Haziran 2009 - 22:18:04

Alıntı

1.Pulseaudio'yu silmek
Kod:

$ sudo mv /etc/X11/Xsession.d/70pulseaudio ~/


2.Pulseaudio kullanımını kapatmak
direkt kapatalım(overkill)
Kod:

sudo update-rc.d pulseaudio stop 50 2 3 4 5 .


öntanıtımlı ayarlardan kaldıralım:
Kod:

asoundconf unset-pulseaudio
asoundconf set-default-card Intel



libao.conf'u alsa'ya çevirelim(ctrl-x ile kaydedin)
Kod:

sudo nano /etc/libao.conf
default_driver=alsa




son kısmı "default_driver=pulseaudio" yaptım. koyu olan yerleri nasıl yapacağım hakkında hiçbir fikrim yok. 2. maddede geri alınacak * bir şey yok gibi. 1. madde içinde synapticten pulseaudiolu *bir şeyler kurdum ama zaten pulseaudio kuruluymuş.

yaptıklarım doğru olmuş mu? ve yapamadiğim yer için ne yapmam lazim.

@heartsmagic benim kod bilgim kopyala yapıştırdan ibaret :D
« Son Düzenleme: 09 Haziran 2009 - 22:18:04 Gönderen: ns »
Madem ki sen bensin, ben de senim, niceye şu senlik benlik...

« Yanıtla #12 : »
@heartsmagic benim kod bilgim kopyala yapıştırdan ibaret :D

@ns bazı konularda bizler de farklı değiliz, hele hele yeni öğrendiğimiz meselelerde :D

Ben senin verdiğin iki komuttan sanırım ilki için içgüdüsel olarak :D

Kod: [Seç]
asoundconf set-pulseaudio
denemiştim. İkincisine dokunmadım bile.

Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #13 : »
ses iyice gitti en baştan tekrar kurayım şu alsayı.:D


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 10 Haziran 2009 - 12:19:11
tüh bee. kulaklık takılı olduğu için duymuyormuşum sesi! acaip kızdım kendime. boş yere yeniden kurdum.
« Son Düzenleme: 10 Haziran 2009 - 12:19:11 Gönderen: ns »
Madem ki sen bensin, ben de senim, niceye şu senlik benlik...

« Yanıtla #14 : »
tüh bee. kulaklık takılı olduğu için duymuyormuşum sesi! acaip kızdım kendime. boş yere yeniden kurdum.

Bir musibet, bin nasihatten iyidir :D
Geçmiş olsun.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #15 : »
sağolasın @heartsmagic :D .Bugün başıma gelmeyen musibet kalmadi.
Madem ki sen bensin, ben de senim, niceye şu senlik benlik...

« Yanıtla #16 : »
Kod: [Seç]
/etc/mplayer/mplayer.conf
bash: /etc/mplayer/mplayer.conf: Permission denied
bende ses tamamen gitti, alsa derlemesi yapayım dedim.
fakat bu adımda takılıyorum.
ne yapabilirim?

« Yanıtla #17 : »
Aşağıdaki ile açabilirsiniz:

Kod: [Seç]
sudo gedit /etc/mplayer/mplayer.conf
Umut en büyük kötülüktür; işkenceyi uzatır. - F.N.

Bir şey ne ise odur, bu kadar. Öyleyse, iki şey arasında bağdaşıklık varsa, bu aralarında iletişim kuruyorlar demek değildir.
"... kavrayışını bilgi ile derinleştir ..."
PF @ ST

« Yanıtla #18 : »
teşekkürler çözdüm

« Yanıtla #19 : »
*ya ben bunları yaparken internet bağlantım gitti..

saddece son bölümünü yapamamıştım

 /etc/mplayer/mplayer.conf

onu da son sayfada bi arkadaş yazmış nerden girileceğini..

peki internet neden gitti sizce nerede hata yaptım da bağlantı koptu??

« Yanıtla #20 : »
ses geliyor mu?
bunun internet ile ilgisi yok...
Sadece 8.10'da overkill yaparken internet servislerinden birinin Tikini kaldırmış olabilirsin...

« Yanıtla #21 : »
ses geliyor mu?
bunun internet ile ilgisi yok...
Sadece 8.10'da overkill yaparken internet servislerinden birinin Tikini kaldırmış olabilirsin...

ses gelmiyor..

yeniden yükledim ubuntuyu..tekrar deniyeceğim sesi..

ama dediğin doğru olabilir..ben bütün tikleri kaldırmıştım..

nese tekrar deniyelim bu seferde ses çıkmassa pardusa yöneleceğim..yeter artık sabahtan beri etmediğim maymunluk kalmadı


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 12 Temmuz 2009 - 15:28:41
Sisteminizin Sesinde Sorun Yoksa Sakın Denemeyin!!!!


9.04 jaunty jackakobe için:

aynı bağımlılıklar:
Kod: [Seç]
% sudo apt-get install alsa-oss
% sudo apt-get install libasound2
% sudo apt-get install libasound2-plugins
% sudo apt-get install sysv-rc-conf

1.Pulseaudio'yu silmek
Kod: [Seç]
$ sudo mv /etc/X11/Xsession.d/70pulseaudio ~/
2.Pulseaudio kullanımını kapatmak
direkt kapatalım(overkill)
Kod: [Seç]
sudo update-rc.d pulseaudio stop 50 2 3 4 5 .
öntanıtımlı ayarlardan kaldıralım:
Kod: [Seç]
asoundconf unset-pulseaudio
asoundconf set-default-card Intel

libao.conf'u alsa'ya çevirelim(ctrl-x ile kaydedin)
Kod: [Seç]
sudo nano /etc/libao.conf
default_driver=alsa

sesteki herşeyi alsaya çevirin

3.ince ayar
Kod: [Seç]
sudo gedit /etc/pulse/client.conforadaki "autospawn = yes" yazısını "autospawn = no" yapın

Kod: [Seç]
sudo gedit /etc/pulse/default.paalttaki yazıları bulun
Kod: [Seç]
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
ve hamen altına bu yazıları ekleyin
Kod: [Seç]
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
ve kaydedin.

Kod: [Seç]
sudo gedit /usr/share/alsa/alsa.confu açın ve ‘/usr/share/alsa/pulse.conf‘ u bulun ve yanına # yerleştirin
böyle * bir şey olacak
Kod: [Seç]
@hooks [
    {
        func load
        files [
#           "/usr/share/alsa/pulse.conf"
            "/usr/share/alsa/bluetooth.conf"
            "/etc/asound.conf"
            "~/.asoundrc"
        ]
        errors false
    }
ve kaydededin

Kod: [Seç]
sudo gedit /etc/mplayer/mplayer.confyazın ve
Kod: [Seç]
# Specify default audio driver ao=pulse,alsa,
Kod: [Seç]
ao=alsaya çevirin
Kod: [Seç]
alsamixeryazın ve sesi istediğiniz ayara getirin

ve reset atın
iyi müzikler  ;D
kaynak: 9.04 Alsa

ilk yüklemeleri yapıyorum.sonra yazıyorum terminale ilk kodu yani sudo mv /etc/X11/Xsession.d/70pulseaudio ~/ cevap olarak bana mv: "/etc/X11/Xsession.d/70pulseaudio' durumlanamadı: No such file or directory
 veriyor..lütfen yardım bugün halletmeliyim bu ses işini..


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 12 Temmuz 2009 - 18:04:49
olmuyor arkadaşlar..diğer çözümlenmiş konuların çoğuna baktım orda yazanları da yaptım her yapışımdan sonra *yeniden başlattım hala ses yok..ne sistem açılırken ne internette video izlerken ne de müzik oynatmaya kalkınca..çalıyor görünüyor ama çalmıyor


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 12 Temmuz 2009 - 21:08:01
onu atladım bu sefer en sonlardaki sudo gedit /etc/mplayer/mplayer.conf yazıyorum

gedit açılıyor ama içi boş..dolayısıyla # Specify default audio driver ao=pulse,alsa, burdaki ao=alsa yapamıyorum

« Son Düzenleme: 12 Temmuz 2009 - 21:08:01 Gönderen: berkan402 »

« Yanıtla #22 : »
mplayer kurulu değilse zaten öyle bir dosya olmaz.

Sen şu ana kadar ne yaptıysan tam tersini uygula.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #23 : »
gerek kalmadı zati çözdüm ses problemini..açtığım başlıkta da var nasıl çözdüğüm

« Yanıtla #24 : »
bunları yapmama gerek var mı. problemim farklı mı diye sormak istedim :)

benim seste bir sorunum vardı. bilgisayar her açıldığında ses hem laptobun kendi hoparlörlerinden hem de kulaklık çıkışına bağlı olan 5 artı birden geliyordu. ben kulaklıkta takılı olan kabloyu çıkartıp yeniden takınca laptop susuyor olması gerektiği gibi sadece 5 artı birden geliyordu. bir arkadaşımdan yardım aldım. alsayı kurman lazım dedi. dediklerini yaptım şimdi ses her ikisinden geliyor ama kabloyu çıkarttığım halde düzelmiyor. :(

yaptığım işlemleri yazabilirim........


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 09 Ağustos 2009 - 17:11:43
yaptıklarımız:

aptitude install build-essential libncurses-dev gettext linux-headers-`uname -r` xmlto

sudo su
mkdir /usr/src/alsa
cd /usr/src/alsa
wget -c ftp://ftp.task.gda.pl/pub/linux/misc/alsa/driver/alsa-driver-1.0.20.tar.bz2
wget -c ftp://ftp.task.gda.pl/pub/linux/misc/alsa/lib/alsa-lib-1.0.20.tar.bz2
wget -c ftp://ftp.task.gda.pl/pub/linux/misc/alsa/utils/alsa-utils-1.0.20.tar.bz2
 tar xvf alsa-driver-1.0.20.tar.bz2
cd alsa-driver-1.0.20
./configure --with-cards=hda-intel
make
 make install
cd ..
tar xvf alsa-lib-1.0.20.tar.bz2
cd alsa-lib-1.0.20
./configure
make
make install
cd ..
tar xvf alsa-utils-1.0.20.tar.bz2
tar xvf alsa-utils-1.0.20.tar.bz2
./configure
make
make install
 cat /proc/asound/card0/codec#* | grep Codec

Codec: Realtek ALC268
Codec: Conexant ID 2c06


 gedit /etc/modprobe.d/alsa-base.conf

en alt kısma bunu ekledim

options snd-hda-intel model=3stack

sonra yeniden başlattım ama olmadı. :(


« Son Düzenleme: 09 Ağustos 2009 - 17:11:43 Gönderen: ibokozan »