Gönderen Konu: [Nasıl] Hoparlorler için ALSA derlemesi (ubuntu 8.10,9.04)  (Okunma sayısı 14838 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« Yanıtla #1 : »
Sisteminizin Sesinde Sorun Yoksa Sakın Denemeyin!!!!

8.10 intrepid ibex için:

Kendim bunu kullanıyorum çok güzel ve iyi ses veriyor ;)
1.Pulseaudio'yu silmek
en başta gereken bağımlılıkları kuralım:
Kod: [Seç]
% sudo apt-get install alsa-oss
% sudo apt-get install libasound2
% sudo apt-get install libasound2-plugins
% sudo apt-get install sysv-rc-conf

sonra pulseaudio'yu gnome-settings-deamon'dan silelim:
Kod: [Seç]
% gconftool-2 -s -t bool /apps/gnome_settings_daemon/plugins/sound/active false
pulseaudio'yu kapatalım:
Kod: [Seç]
% asoundconf unset-pulseaudio
runlevel'den silelim(overkill)
sayfayı aşağıya indirdiğinizde pulseaudio yazan yerler olacak
oradaki tkleri kaldıralım
Kod: [Seç]
% sudo sysv-rc-conf
2.ALSA ayarları

Kod: [Seç]
% asoundconf list
yazalım, gelen çıktı şöyle * bir şey olacaktır:
Kod: [Seç]
Names of available sound cards:
Intel

ve orada çıkan kartı varsayılan yapınız:
Kod: [Seç]
% asoundconf set-default-card Intel
Ve şimdi sistem>tercihler>ses teki ayarları şu şekilde yapınız



ve restart yapınız şimdilik bir açılış sesiniz olmayacak ama
reset attıktan sonra açılış sesini açabilirsiniz.  ;)

Kaynak: ALSA instead of Pulseaudio
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
9.04 jaunty jackakobe için:

aynı bağımlılıklar:
Kod: [Seç]
% sudo apt-get install alsa-oss
% sudo apt-get install libasound2
% sudo apt-get install libasound2-plugins
% sudo apt-get install sysv-rc-conf

1.Pulseaudio'yu silmek
Kod: [Seç]
$ sudo mv /etc/X11/Xsession.d/70pulseaudio ~/
2.Pulseaudio kullanımını kapatmak
direkt kapatalım(overkill)
Kod: [Seç]
sudo update-rc.d pulseaudio stop 50 2 3 4 5 .
öntanıtımlı ayarlardan kaldıralım:
Kod: [Seç]
asoundconf unset-pulseaudio
asoundconf set-default-card Intel

libao.conf'u alsa'ya çevirelim(ctrl-x ile kaydedin)
Kod: [Seç]
sudo nano /etc/libao.conf
default_driver=alsa

sesteki herşeyi alsaya çevirin

3.ince ayar
Kod: [Seç]
sudo gedit /etc/pulse/client.conforadaki "autospawn = yes" yazısını "autospawn = no" yapın

Kod: [Seç]
sudo gedit /etc/pulse/default.paalttaki yazıları bulun
Kod: [Seç]
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
ve hamen altına bu yazıları ekleyin
Kod: [Seç]
load-module module-alsa-sink device=dmix
load-module module-alsa-source device=dsnoop
ve kaydedin.

Kod: [Seç]
sudo gedit /usr/share/alsa/alsa.confu açın ve ‘/usr/share/alsa/pulse.conf‘ u bulun ve yanına # yerleştirin
böyle * bir şey olacak
Kod: [Seç]
@hooks [
    {
        func load
        files [
#           "/usr/share/alsa/pulse.conf"
            "/usr/share/alsa/bluetooth.conf"
            "/etc/asound.conf"
            "~/.asoundrc"
        ]
        errors false
    }
ve kaydededin

Kod: [Seç]
sudo gedit /etc/mplayer/mplayer.confyazın ve
Kod: [Seç]
# Specify default audio driver ao=pulse,alsa,
Kod: [Seç]
ao=alsaya çevirin
Kod: [Seç]
alsamixeryazın ve sesi istediğiniz ayara getirin

ve reset atın
iyi müzikler  ;D
kaynak: 9.04 Alsa
« Son Düzenleme: 12 Temmuz 2009 - 17:48:10 Gönderen: maxxblade »

« Yanıtla #25 : »
Alıntı
options snd-hda-intel model=3stack
bunun olduğundan emin misin? Kendi kartın için doğru parametere bu mu?
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #26 : »
bilmiyorum

 cat /proc/asound/card0/codec#* | grep Codec

yazdığımda

bunlar çıkıyor

Codec: Realtek ALC268
Codec: Conexant ID 2c06


doğru parametreler nedir? nasıl öğrenebilirim.

« Yanıtla #27 : »
Forumdaki ALSA derlemesi başlığında anlatılıyor.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #28 : »
 /etc/mplayer/mplayer.conf

bu dosyanın olmadığını söylüyor.içindekileri değiştiremiyorum.Ne yapacağım peki?bir fikri olan var mı?


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 19 Ağustos 2009 - 23:38:21
Aşağıdaki ile açabilirsiniz:

Kod: [Seç]
sudo gedit /etc/mplayer/mplayer.conf

bende bu dosyanın olmadığını söyledi ne yapabilirm?

« Yanıtla #29 : »
Mplayer kullanmıyorsan zaten o dosya olmaz, değiştirmene gerek de olmaz.
Fakat baştan belirteyim ki, buradaki yöntem arada bir iç açıcı olmayan sonuçlar doğurabiliyor.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #30 : »
 :'(ya ben önceden compaq presario cq60-130et kullanıyordum onda kablosuz internet hariç hiçbir sorunum yoktu.servise verdim tamir edemediler şimdi pavilion dv6-1143et verdiler yerine ama burnumdan geldi ses yok wireless gene yok o heralde modemden kaynaklanıyor ne denediysem çözemedim..acaba ekran kartı öncekinin nvidia iken şimdikinin ati diye sorun çıkarıyor olabilir diye düşündüm ama doğru mudur?oyun falan kuramıyorum ses olmayınca çıldırıcağım yaa..ne yaptıysam çözüm bulamadım...interneti geçtim sadece sesi halletsem kafidir.şimdi mecbur ubuntunun yanında vista kullanıyorum kendimi kirletilmiş hissediyorum:D..ve aşırı da yavaş * bir şey ya tiksindim.

« Yanıtla #31 : »
Ses sorunun için ilk olarak bu başlığa bakma. Şu an yaptıklarını geri al.
Kod: [Seç]
lspci çıktında gördüğün ses kartına göre forumda arama yapıp bir başlıkta geçiyor mu diye kontrol et. Eğer geçmiyorsa yeni bir başlıkta sor.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #32 : »
deneyeceğim,teşekkür ederim.

« Yanıtla #33 : »
9.10 için buradaki aşamaları denedim, her şey çok güzel oldu sesler düzelmişti fakat bilgisayarı baştan başlattıktan artık ses gelmemeye başladı =/ ne yapabilirim bunun için ?

« Yanıtla #34 : »
9.10 için buradaki aşamaları denedim, her şey çok güzel oldu sesler düzelmişti fakat bilgisayarı baştan başlattıktan artık ses gelmemeye başladı =/ ne yapabilirim bunun için ?

Yaptığın değişiklikler yerinde duruyor mu? Ya da yeniden yaptın mı?
Umut en büyük kötülüktür; işkenceyi uzatır. - F.N.

Bir şey ne ise odur, bu kadar. Öyleyse, iki şey arasında bağdaşıklık varsa, bu aralarında iletişim kuruyorlar demek değildir.
"... kavrayışını bilgi ile derinleştir ..."
PF @ ST

« Yanıtla #35 : »
dosyalarda yaptığım değişiklikler duruyo. aynı şeyleri tekrar yapmaya çalıştım, 0 paket kuruldu vs gibi şeyler yazdı yani onlarda kurulu. fakat dün de bugünde asoundcond ile başlayan kodlarda command not found hatası veriyordu. ilk başta sorun olur sanmıştım ama ses düzelince önemsemedim. ondan dolayı olabilir mi ?

venividivinco@venividivinco-laptop:~$ asoundconf unset-pulseaudio
asoundconf: command not found

« Yanıtla #36 : »
Bu işlem bir de Ubuntu 9.10 için nasıl yapılıyor açıklansa iyi olur.

« Yanıtla #37 : »
Bu işlem bir de Ubuntu 9.10 için nasıl yapılıyor açıklansa iyi olur.

Şiddetle katılıyorum :D
“Özgür yazılım ile özel mülk yazılım arasındaki fark sosyal, etik ve siyasidir” Richard Stallman

Debian Sosyal Sözleşme
 http://www.debian.org/social_contract.1.0.tr.html  saimbalkaya.blogspot.com guvercincurnatasi.wordpress.com