Gönderen Konu: Software Updater:Güncelleme yapamıyorum.  (Okunma sayısı 406 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« Yanıtla #1 : »
Ekranın sol üst köşesinde kırmızı bir şekilde dur işareti var ve güncelleme yapmak istediğim zaman bu https://i.hizliresim.com/BalP0g.png hatayı alıyorum.

Nasıl düzeltebileceğim hakkında yardımcı olabilir misiniz?
« Son Düzenleme: 04 Mayıs 2019 - 10:31:31 Gönderen: mfb14 »

« Yanıtla #25 : »
@illedelinux

Dediğiniz gibi yaptım kendi source.list içeriğimi silip sizinkiyle değitirip

Kod: [Seç]
sudo apt update komutu çalıştırdım.

Daha sonra güncelleme yaptığım zaman yine aynı hataları aldım
Kod: [Seç]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libnvidia-ifr1-390 : Depends: libnvidia-gl-390 but it is not installed
 nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Recommends: nvidia-prime (>= 0.8) but it is not installed
                     Recommends: libnvidia-ifr1-390:i386 (= 390.116-0ubuntu0.18.04.1)
                     Recommends: libnvidia-gl-390:i386 (= 390.116-0ubuntu0.18.04.1)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


« Yanıtla #26 : »
Yeni sources.list dosyasının ardından aşağıdaki komutu dener ve çıktısını atar mısınız?

Kod: [Seç]
sudo apt install -f && sudo apt --fix-broken install
Bu açıklanamaz, ama hissedersin. Hayatın boyunca dünyayla ilgili bazı şeylerin yanlış olduğunu hissetmişsindir. Ne olduğunu bilmezsin, ama o oradadır; beynine saplanmış bir kıymık parçası gibi... Seni deli eder.

« Yanıtla #27 : »
@Empat
Kod: [Seç]
sudo apt install -f && sudo apt --fix-broken install
Kod: [Seç]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  lib32gcc1 libc6-i386 libwayland-client0:i386 libwayland-server0:i386
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libnvidia-gl-390
The following NEW packages will be installed:
  libnvidia-gl-390
0 upgraded, 1 newly installed, 0 to remove and 99 not upgraded.
9 not fully installed or removed.
Need to get 14,3 MB of archives.
After this operation, 73,8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.nluug.nl/os/Linux/distr/ubuntu bionic-updates/restricted amd64 libnvidia-gl-390 amd64 390.116-0ubuntu0.18.04.1 [14,3 MB]
Fetched 14,3 MB in 10s (1.409 kB/s)                                           
(Reading database ... 235098 files and directories currently installed.)
Preparing to unpack .../libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb ...
diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340
dpkg-divert: error: mismatch on package
  when removing 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 by libnvidia-gl-390'
  found 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340'
dpkg: error processing archive /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb (--unpack):
 new libnvidia-gl-390:amd64 package pre-installation script subprocess returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb
libdvd-pkg: Checking orig.tar integrity...
/usr/src/libdvd-pkg/libdvdcss_1.4.2.orig.tar.bz2: OK
libdvd-pkg: `apt-get check` failed, you may have broken packages. Aborting...
E: Sub-process /usr/bin/dpkg returned an error code (1)

« Yanıtla #28 : »
Size verdiğim bu adrestekini denerseniz sorun çözülür tahmin ediyorum.
Kod: [Seç]
https://itsfoss.com/dpkg-returned-an-error-code-1/   
Şimdi bu adresteki yönergeye göre şöyle bir sırlama yapmış.
Kod: [Seç]
sudo dpkg --configure -a
Kod: [Seç]
sudo apt-get install -f
Kod: [Seç]
sudo apt remove  sorunlu-paket
Bunlar çözüm olmayınca alttaki komutla sorunlu paketi ve bağımlılıklarını listelemiş.
Kod: [Seç]
ls -l /var/lib/dpkg/info | grep -i  sorunlu-paket 
Sonra paketi ve bağımlılıkları şu şekil ortadan kaldırmış,
Kod: [Seç]
sudo mv /var/lib/dpkg/info/sorunlu-paket.* /tmp   
Sonra alttaki komutla mutlu sona ulaşmış.
Kod: [Seç]
sudo apt update
GNU/Linux kullanmıyorum, onu yaşıyorum...

« Yanıtla #29 : »
Galiba hatayı çözerken birşeyleri karıştırdım yine hatalar alıyorum

Kod: [Seç]
sudo apt-get upgrade
Kod: [Seç]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 cuda-drivers : Depends: nvidia-settings (>= 384.81) but it is not installed
                Depends: nvidia-opencl-icd-384 (>= 384.81) but it is not installed
 libcuinj64-9.1 : Depends: libcuda1 (>= 387.26) or
                           libcuda-9.1-1
 nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: nvidia-dkms-390 (= 390.116-0ubuntu0.18.04.1)
                     Depends: nvidia-kernel-source-390 (= 390.116-0ubuntu0.18.04.1)
                     Depends: libnvidia-compute-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: nvidia-compute-utils-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: libnvidia-decode-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: libnvidia-encode-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: libnvidia-cfg1-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: libnvidia-ifr1-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Depends: libnvidia-fbc1-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                     Recommends: nvidia-settings but it is not installed
                     Recommends: nvidia-prime (>= 0.8) but it is not installed
                     Recommends: libnvidia-compute-390:i386 (= 390.116-0ubuntu0.18.04.1)
                     Recommends: libnvidia-decode-390:i386 (= 390.116-0ubuntu0.18.04.1)
                     Recommends: libnvidia-encode-390:i386 (= 390.116-0ubuntu0.18.04.1)
                     Recommends: libnvidia-ifr1-390:i386 (= 390.116-0ubuntu0.18.04.1)
                     Recommends: libnvidia-fbc1-390:i386 (= 390.116-0ubuntu0.18.04.1)
                     Recommends: libnvidia-gl-390:i386 (= 390.116-0ubuntu0.18.04.1)
 nvidia-headless-390 : Depends: nvidia-dkms-390
 nvidia-headless-no-dkms-390 : Depends: nvidia-kernel-source-390 (= 390.116-0ubuntu0.18.04.1)
                               Depends: libnvidia-compute-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
                               Depends: nvidia-compute-utils-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
 nvidia-utils-390 : Depends: libnvidia-compute-390 but it is not installed
 xserver-xorg-video-nvidia-390 : Depends: libnvidia-cfg1-390 (= 390.116-0ubuntu0.18.04.1) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).