Gönderen Konu: [Çözüldü] Cisco Packet Tracer Giriş Ekranı ve ı - i Harf Sorunu  (Okunma sayısı 180 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Merhaba

Ubuntu 18.04.01 LTS fiziki makine üzerinde Cisco Packet Tracer 7.2.1 kurdum. Program açılışı sırasında kullanıcı bilgilerimi girmem gereken ekran gelmiyor. Altta user login ve guest login geliyor. Ancak bilgilerimi giremediğim için user login ile giriş yapamıyorum. Guest Login ile giriş yaptığım zaman program içerisinde hiç bir şekilde ı ve i harflerini kullanamıyorum(mesela ping yazamıyorum). Hem Türkçe hem de İngilizce klavyede bu tuşlar çalışmıyor. Sorunlar hakkında bilgisi olan var mıdır?

2017 yılında benzer bir sorunla ilgili konu açılmış ancak cevap gelmemiş.
https://resimyukle.xyz/i/Qx33L
https://forum.ubuntu-tr.net/index.php?topic=56769.msg627720#msg627720
« Son Düzenleme: 09 Şubat 2019 - 21:57:58 Gönderen: buri »

« Yanıtla #1 : »
Aşağıdaki komutu çalıştırdıktan sonra durum ne oluyor?

Kod: [Seç]
export LC_ALL=C

« Yanıtla #2 : »
Aşağıdaki komutu çalıştırdıktan sonra durum ne oluyor?

Kod: [Seç]
export LC_ALL=C

Bu komutu işe yaradı. Teşekkür ederim.

Son olarak Packet Tracer prgramı ilk yüklediğim zaman görüntüsü çok iyiydi. Ancak bilgisayarı yeniden başlattıktan sonra program penceresi çok büyüdü, simgeler, menüler gibi program içindeki sekmeler çok büyük gözüküyor.
Ayarlara baktım ama bulamadım. İlk haline nasıl getirebilirim?

« Yanıtla #3 : »
Alıntı
Bu komutu işe yaradı. Teşekkür ederim.

Rica ederiz. Yukarıdaki komut etkisini yeniden başlatınca yitirir. Bu uygulamayı uçbirimden bir komut ile mi çalıştırıyorsunuz, yoksa bir başlatıcı dosyası mı var. Buna göre ayarı kalıcı yapmak için gerekli yönlendirmeyi yapalım.

Alıntı
Ancak bilgisayarı yeniden başlattıktan sonra program penceresi çok büyüdü, simgeler, menüler gibi program içindeki sekmeler çok büyük gözüküyor.
Ayarlara baktım ama bulamadım. İlk haline nasıl getirebilirim?


HiDPI desteği ile ilgili bir sorun olabilir. Aşağıdaki komutu çalıştırınca durum ne oluyor?

Kod: [Seç]
export QT_DEVICE_PIXEL_RATIO=auto

« Yanıtla #4 : »
Rica ederiz. Yukarıdaki komut etkisini yeniden başlatınca yitirir. Bu uygulamayı uçbirimden bir komut ile mi çalıştırıyorsunuz, yoksa bir başlatıcı dosyası mı var. Buna göre ayarı kalıcı yapmak için gerekli yönlendirmeyi yapalım.

Uçbirimden komutu girerek çalıştırıyorum. Kalıcı yapmak için ne yapmak lazım?

Alıntı
HiDPI desteği ile ilgili bir sorun olabilir. Aşağıdaki komutu çalıştırınca durum ne oluyor?

Kod: [Seç]
export QT_DEVICE_PIXEL_RATIO=auto

Bu komut işe yaramadı malasef.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 08 Şubat 2019 - 21:36:00
Ekran çözünürlüğüm nordalde 1920x1080(16:9) olarak ayarlı. Çözünürlüğü 1600x900(16:9) olarak ayarladığım zaman Packet Tracer biraz daha iyi gözüküyor.
Ama programı ilk yüklediğim zaman ki gibi değil yine. İlk yüklediğim zaman çok güzeldi, neden böyle bir şey yaptı...  :o
« Son Düzenleme: 08 Şubat 2019 - 21:36:00 Gönderen: buri »

« Yanıtla #5 : »
Başlatıcı komut ayarını kalıcı yapmak için, aşağıdaki komutlarla alias oluşturmayı deneyebilirsiniz.

Kod: [Seç]
echo "alias packettracer='env LC_ALL=C packettracer'" | tee -a ~/.bashrc
source ~/.bashrc

Packet Tracer /etc/profile dosyasına QT_DEVICE_PIXEL_RATIO ile ilgili değişken ekliyormuş. Uygulamayı ilk kurduğunuzda bu değişken etkin olmamıştır, yeniden başlatınca etkin olarak görünümü bozmuş olabilir. Aşağıdaki komutu çalıştırınca sorun düzeliyorsa, bu dosyadaki değişkeni buna göre değiştirmeyi deneyebilirsiniz.

Kod: [Seç]
export QT_DEVICE_PIXEL_RATIO=2
Bu şekilde sonuç değişmezse aşağıdaki komutu denersiniz.

Kod: [Seç]
export QT_DEVICE_PIXEL_RATIO=1
Hangi komut daha sorunu çözerse, /etc/profile dosyasını buna göre düzenlersiniz. QT_DEVICE_PIXEL_RATIO değerini değiştereceksiniz.


« Yanıtla #6 : »
/etc/profile dosyasında Packet Tracer ile ilgili kısım aşağıdaki gibiydi;

Kod: [Seç]
PT7HOME=/opt/packetracer
export PT7HOME
QT_DEVICE_PIXEL_RATIO=auto
export QT_DEVICE_PIXEL_RATIO

3. satırın sonundaki auto olan yeri 1 olarak değiştirdim. Bu şekilde programı açtığımda bir değişiklik olmadı ancak bilgisayarı yeniden başlatıp programı açtığımda istediğim görüntüyü elde ettim.
.bashrc dosyasında da ilgili LC_ALL=C değişikliğini yaptım, sorunsuz şekilde açılıyor şu an.

İlginiz ve desteğiniz için çok teşekkür ederim.

« Yanıtla #7 : »
Rica ederiz. Çözüme ulaşan başlıklar için şunu uygulayabilirsiniz. Çözülen başlıkların etiketlenmesi


Değişikliklerin kabukta etkili olması için, source komutunu kullanabilirdiniz. Bu şekilde yeniden başlatmaya gerek kalmaz.

Kod: [Seç]
source /etc/profile