Gönderen Konu: NVİDİA GTX 1060 Uyku sorunu problemi  (Okunma sayısı 348 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Merhaba arkadaşlar bilgisayarıma ubuntu kurdum. açık kaynak grafik kartını kullanıyorum şuan uyku moduna girdiği zaman ekran tekrardan gelmiyor. kapalı kaynak kurulumu yaptığım zaman ise 800x600 ekran boyutlarından açılıyor bilgisayar ve başka bir çözünürlük yok 800x600 de kalıyor ama sorun ortadan kalkıyor ama bu seferde bilgisayar açılırken siyah arka planda [x32] şeklinde *bir şeyler yazarak açılıyor sorun nedir gün içerisinde 3 kez kurulum yaptım yardım lütfen :(

lspci -nnk | egrep "VGA|3D|Display" çıktısı bu şekilde

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c60] (rev a1)
alimert@alimert-OMEN-by-HP-Laptop-15

glxinfo | grep render çıktısı bu şekilde
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: NV136
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
    GL_MESA_texture_signed_rgba, GL_NV_conditional_render, GL_NV_depth_clamp,
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fill_rectangle,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

xrandr çıktısı da bu şekilde
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   3840x2160     60.02*+  30.04 
   1920x1200     59.95 
   1920x1080     60.00 
   1600x1200     59.95 
   1680x1050     60.00 
   1400x1050     60.00 
   1280x1024     59.95 
   1280x960      59.99 
   1152x864      59.97 
   1024x768      59.95 
   800x600       59.96 
   640x480       59.94 
   720x400       59.97 
   640x400       59.96 
   640x350       59.84 
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)



« Yanıtla #1 : »
inxi paketini yükleyip aşağıdaki komutların çıktılarını kod etiketi içinde paylaşır mısınız?

Kod: [Seç]
inxi -SGMxx
ubuntu-drivers list
dpkg -l | grep nvidia
cat /etc/fstab
sudo blkid
cat /proc/swaps
cat /etc/initramfs-tools/conf.d/resume
cat /proc/cmdline

« Yanıtla #2 : »
inxi -SGMxx

Kod: [Seç]
System:    Host: alimert-OMEN-by-HP-Laptop-15-ce0xx Kernel: 4.15.0-36-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.28.3 (Gtk 3.22.30-1ubuntu1) dm: gdm3
           Distro: Ubuntu 18.04.1 LTS
Machine:   Device: laptop System: HP product: OMEN by HP Laptop 15-ce0xx serial: N/A
           Mobo: HP model: 8390 v: 40.28 serial: N/A
           UEFI: American Megatrends v: F.17 date: 06/19/2018
           Chassis: type: 10 serial: N/A
Graphics:  Card: NVIDIA GP106M [GeForce GTX 1060 Mobile]
           bus-ID: 01:00.0 chip-ID: 10de:1c60
           Display Server: x11 (X.Org 1.19.6 ) driver: nouveau
           Resolution: 3840x2160@60.02hz
           OpenGL: renderer: NV136
           version: 4.3 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes

ubuntu-drivers list
Kod: [Seç]
nvidia-driver-390

dpkg -l | grep nvidia -> Hiç Bir sonuç vermeden aşağı satıra atlıyor

cat /etc/fstab
Kod: [Seç]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=4ae73341-8cd6-423c-91ef-2ae00f3f7fbc /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=9E50-7EA3  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

sudo blkid
Kod: [Seç]
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop5: TYPE="squashfs"
/dev/loop6: TYPE="squashfs"
/dev/loop7: TYPE="squashfs"
/dev/nvme0n1: PTUUID="0778d948-8312-4395-8239-d3a8155a7d23" PTTYPE="gpt"
/dev/nvme0n1p1: UUID="9E50-7EA3" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="38cba627-0905-432c-b63e-23e1c7647fd7"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="2616e16f-4bcf-4f26-9d22-aa4a97f1204f"
/dev/nvme0n1p3: LABEL="Windows" UUID="6CF24337F2430534" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f40f8fef-e8ac-435e-87fc-bfbd784b0915"
/dev/nvme0n1p4: LABEL="Windows RE tools" UUID="8E58B38358B3689B" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ac2267b1-cc9b-4dee-915e-b3f05fbae774"
/dev/nvme0n1p5: UUID="4ae73341-8cd6-423c-91ef-2ae00f3f7fbc" TYPE="ext4" PARTUUID="53ae1f97-faa6-4a16-8d64-7d6cb188fa91"
/dev/sda1: LABEL="DATA" UUID="D08C2C5C8C2C3F7A" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a0528abc-e4f7-4402-8260-9fbffc0ee964"
/dev/sda2: LABEL="RECOVERY" UUID="CE6E2DAC6E2D8DF1" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="e5e7cbc9-2bce-44de-929d-fab00b1cdfc8"
/dev/loop8: TYPE="squashfs"

cat /proc/swaps
Kod: [Seç]
alimert@alimert-OMEN-by-HP-Laptop-15-ce0xx:~$ cat /proc/swaps
Filename Type Size Used Priority
/swapfile                               file 2097148 0 -2

cat /etc/initramfs-tools/conf.d/resume
Kod: [Seç]
cat /etc/initramfs-tools/conf.d/resume
cat: /etc/initramfs-tools/conf.d/resume: Böyle bir dosya ya da dizin yok

cat /proc/cmdline
Kod: [Seç]
BOOT_IMAGE=/boot/vmlinuz-4.15.0-36-generic root=UUID=4ae73341-8cd6-423c-91ef-2ae00f3f7fbc ro quiet splash vt.handoff=1

sonuçlar bu şekilde dpkg -l | grep nvidia çalımadı direk aşağı satıra atıyor farklı komut girebiliyorum. cat: /etc/initramfs-tools/conf.d/resume dosya yok diyor

« Yanıtla #3 : »
Alıntı
/swapfile                               file      2097148   0   -2

Takas alanı yerine takas dosyası kullanıyorsunuz. Bunun yerine takas alanı oluşturmanız hazırda bekletme kipi için daha uygun. Takas dosyası ile hazırda bekletme sorunları olabiliyor. Aşağıdaki komutun çıktısıyla diskin durumunu öğrenelim. Duruma göre takas dosyası yerine takas alanı oluşturmayı denetebiliriz.

Kod: [Seç]
sudo parted -l
Sürücü kurulumu için BIOS'tan secure boot özelliğinin kapalı olduğundan emin olunuz. Bununla birlikte sürücü kurulumunu hazırda bekletme sorunu sonrasına bırakalım.

« Yanıtla #4 : »
Çıktı bu şekilde
Kod: [Seç]
sudo] password for alimert:
Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sda: 1000GB
Sektör boyutu (mantıksal/fiziksel): 512B/4096B
Disk bölümü Tablosu: gpt
Disk Bayrakları:

Numara  Başlangıç  Son     Boyut   Dosya sistemi  İsim                  Bayraklar
 1      1049kB     986GB   986GB   ntfs           Basic data partition  msftdata
 2      986GB      1000GB  14,7GB  ntfs           Basic data partition  gizli, msftdata


Model: NVMe Device (nvme)
Disk /dev/nvme0n1: 512GB
Sektör boyutu (mantıksal/fiziksel): 512B/512B
Disk bölümü Tablosu: gpt
Disk Bayrakları:

Numara  Başlangıç  Son    Boyut   Dosya sistemi  İsim                          Bayraklar
 1      1049kB     274MB  273MB   fat32          EFI system partition          önyükleme, esp
 2      274MB      290MB  16,8MB                 Microsoft reserved partition  msftres
 3      290MB      425GB  425GB   ntfs           Basic data partition          msftdata
 5      425GB      511GB  85,9GB  ext4
 4      511GB      512GB  1028MB  ntfs           Basic data partition          gizli, diag

« Yanıtla #5 : »
Alıntı
4      511GB      512GB  1028MB  ntfs           Basic data partition          gizli, diag

Şu disk bölümünden bir miktar alan ayırıp, bunu takas alanı olarak biçimlendir misiniz? Linux altında Gparted ile yapabilirsiniz. Alan RAM miktarının iki katı kadar olsun, çünkü hazırda bekletme için kullanacağız. Ardından aşağıdaki komutun çıktısını paylaşırsınız.

Kod: [Seç]
lsblk -o NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT,UUID

« Yanıtla #6 : »
alan ram miktarının 2 katı olsun demişsiniz sonradan fark ettim hemen düzeltirim onu ext 4 dosya biçimindemi olacak ? bu şekilde doğrumudur ona göre alanı yükselte bilirim bu arada ilginiz ve alakanız için çok teşekkürederim başınızı ağrıtıyorum ama :(

« Yanıtla #7 : »
linux-swap seçeneğini seçmelisiniz. Ayırdığınız alan 20 GB. olan mıdır? Eğer öyleyse ve RAM miktarı 10 GB. ise uygundur.

« Yanıtla #8 : »
ram 16 gb swap alanını 32 olarak düzelttim
Kod: [Seç]
alimert@alimert-OMEN-by-HP-Laptop-15-ce0xx:~$ lsblk -o NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT,UUID
NAME          SIZE TYPE FSTYPE  MOUNTPOINT  UUID
loop0       140,9M loop squashf /snap/gnome
loop1       254,8M loop squashf /snap/phpst
loop2         2,3M loop squashf /snap/gnome
loop3         3,7M loop squashf /snap/gnome
loop4          13M loop squashf /snap/gnome
loop5        86,9M loop squashf /snap/core/
loop6         4,9M loop squashf /snap/canon
loop7        14,5M loop squashf /snap/gnome
loop8        34,7M loop squashf /snap/gtk-c
sda         931,5G disk                     
├─sda1      917,9G part ntfs                D08C2C5C8C2C3F7A
└─sda2       13,7G part ntfs                CE6E2DAC6E2D8DF1
nvme0n1       477G disk                     
├─nvme0n1p1   260M part vfat    /boot/efi   9E50-7EA3
├─nvme0n1p2    16M part                     
├─nvme0n1p3 363,7G part ntfs                6CF24337F2430534
├─nvme0n1p4   980M part ntfs                8E58B38358B3689B
├─nvme0n1p5    80G part ext4    /           4ae73341-8cd6-423c-91ef-2ae00f3f7fbc
└─nvme0n1p6    32G part swap                209332ea-f235-44a3-b3be-00f5d0d7da77

« Yanıtla #9 : »
Şimdi aşağıdaki komutla /etc/fstab dosyasını açınız.

Kod: [Seç]
gedit admin:///etc/fstab
Aşağıdaki satırın başına # ekleyerek pasifleştiriniz.

Kod: [Seç]
/swapfile                                 none            swap    sw              0       0
Aşağıdaki gibi olacak.

Kod: [Seç]
#/swapfile                                 none            swap    sw              0       0
Ardından aşağıdaki satırları /etc/fstab dosyasının en altına ekleyerek dosyayı kaydediniz.

Kod: [Seç]
#Takas alanı
UUID=209332ea-f235-44a3-b3be-00f5d0d7da77 none            swap    sw              0       0

Ardından aşağıdaki komutu çalıştırınız.

Kod: [Seç]
gedit admin:///etc/initramfs-tools/conf.d/resume
Açılan dosyaya aşağıdaki satırı ekleyip dosyayı kaydediniz.

Kod: [Seç]
RESUME=UUID=209332ea-f235-44a3-b3be-00f5d0d7da77
En son aşağıdaki komutu çalıştırıp sistemi yeniden başlatınız.

Kod: [Seç]
sudo update-initramfs -u
Sistemi yeniden başlattıktan sonra sistemi uykuya alıp uyandırmayı deneyebilirsiniz.

« Yanıtla #10 : »
 gedit admin:///etc/initramfs-tools/conf.d/resume

bu şekilde bir hata alıyorum :(

« Yanıtla #11 : »
Aşağıdaki komutu çalıştırdıktan sonra yeniden deneyin.

Kod: [Seç]
sudo touch /etc/initramfs-tools/conf.d/resume

« Yanıtla #12 : »
Bahsettiğiniz komuttan sonra geldi tüm ayarları yapıp yeniden başlattım fakat malesef yine uykuya girdikten sonra ekran gelmiyor. :/ yinede ilgi ve alakanızdan dolayı çok teşekkürederim

« Yanıtla #13 : »
Aşağıdaki komutları sırasıyla çalıştırıp,

Kod: [Seç]
echo 'GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX resume=UUID=209332ea-f235-44a3-b3be-00f5d0d7da77"' | sudo tee  /etc/default/grub.d/swap.cfg
Kod: [Seç]
sudo update-grub
ardından sistemi yeniden başlattıktan sonra dener misiniz?

Eğer sorun çözülmezse aşağıdaki komutlarla Nvidia-410 sürücüsünü kurmayı deneyebilirsiniz.

Kod: [Seç]
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt install nvidia-driver-410 nvidia-settings
sudo nvidia-xconfig



« Yanıtla #14 : »
Kapalı kaynak driver 390 ı kurdum şuan secure bot u kapatıp oldu ekran düzgün geldi uyku modundan hemen çıkıyor

https://www.youtube.com/watch?v=TpTjQLGzD7U&feature=youtu.be&fbclid=IwAR0EhG-lZyGgM66TBHcjgLZzxNR8QelELN5K8AT-BIZDbor-jUUwNKZsfyU

ama kapalı kaynadığı yükleyince bu şekilde açılıyor bilgisayar sebebi nedir düzeltile bilirmi?

ve secure bot u tekrar aktif ettiğimde ekran yine 800x600 oluyor disabled yaptığımda düzeliyor +
« Son Düzenleme: 17 Ekim 2018 - 23:14:26 Gönderen: alimertustundag »

« Yanıtla #15 : »
Nvidia sürücüsü 3. parti olduğu ve çekirdeğe sonradan eklendiği için secure boot ile sorun yaşanmış olabilir. Aslında Nvidia gibi bir firmanın ürücüsünün secure boot ile sorun çıkarmaması gerekirdi. Şu an sistemimde EFI desteği olamdığı için deneyemiyorum maalesef.

Aşağıdaki komutun çıktısına bir bakalım yine de.

Kod: [Seç]
dkms status
apt-cache policy nvidia-driver-390 nvidia-390

Açılıştaki uyarılar disk sınaması (gözardı edilebilir) ve güç yönetimi ile ilgili. Çok mühim ise bunların çözümü için yeni bir konu açmanız daha uygun olacaktır.

« Yanıtla #16 : »
Kod: [Seç]
alimert@alimert-OMEN-by-HP-Laptop-15-ce0xx:~$ dkms status
nvidia, 390.87, 4.15.0-36-generic, x86_64: installed

Kod: [Seç]
alimert@alimert-OMEN-by-HP-Laptop-15-ce0xx:~$ apt-cache policy nvidia-driver-390 nvidia-390
nvidia-driver-390:
  Kurulu: 390.87-0ubuntu0~gpu18.04.1
  Aday:   390.87-0ubuntu0~gpu18.04.1
  Sürüm çizelgesi:
 *** 390.87-0ubuntu0~gpu18.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     390.77-0ubuntu0.18.04.1 500
        500 http://tr.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
     390.48-0ubuntu3 500
        500 http://tr.archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
nvidia-390:
  Kurulu: (hiçbiri)
  Aday:   390.87-0ubuntu0~gpu18.04.1
  Sürüm çizelgesi:
     390.87-0ubuntu0~gpu18.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages
N: '/etc/apt/sources.list.d/' dizinindeki 'google-chrome.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
N: '/etc/apt/sources.list.d/' dizinindeki 'graphics-drivers-ubuntu-ppa-bionic.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor

« Yanıtla #17 : »
Eklediğimiz PPA deposundaki sürümü kurduğunuz için secure boot ile sorun yaşanmış olabilir. Aşağıdaki komutla PPA deposundan kurduğunuz sürümü kaldırıp,

Kod: [Seç]
sudo apt purge --autoremove nvidia-driver-390
ardından aşağıdaki komutlarla depoyu kaldırınız.

Kod: [Seç]
sudo apt install ppa-purge
sudo ppa-purge ppa:graphics-drivers/ppa
sudo apt update

Daha sonra aşağıdaki komutla sürücüyü yeniden kurmayı deneyiniz. Böylece resmi depodaki sürüm kurulabilir.

Kod: [Seç]
sudo ubuntu-drivers autoinstall

« Yanıtla #18 : »
@speakerXXL arkadaşımız sayesinde sonunda problemi çözdük. uyku sorunu probleminde bilgisayarın uyanamaması ve secure boot aktifken nvidia sahipli sürücünün kurulduğu taktirde problemli bir şekilde açılmasının çözümü aşağıdaki gibidir.

Kod: [Seç]
wget --no-check-certificate https://gist.githubusercontent.com/Garoe/74a0040f50ae7987885a0bebe5eda1aa/raw/692394500cfac54732af8f48c855c8bf6b876baf/create-efi-keys.sh

chmod +x create-efi-keys.sh

sudo sh create-efi-keys.sh

yukarıdaki komutları uyguladıktan sonra son komutta sizden şifre isteyecek 123456 gibi birşet belirleye bilirsiniz. geçici secure boot şifresi daha sonra restart attığınızda karşınıza mavi ekranda press key diyecek enter ladığınızda 2. seçenek (enroll MOK ) diyeceksiniz daha sonra (yes) ve komut satırında belirlediğiniz geçici şifreyi gireceksiniz daha sonra bilgisayarınızı secure boot açıkken rahatlıkla açabilecek ve problemler ordan kalmış olacaktır.

@speakerXXL  problemlerimin en başından sonuna kadar destek olduğu için kendisine sonsuz teşekkürlerimi sunuyorum  :))