Gönderen Konu: Ubuntu 18.04 emulator sorunu  (Okunma sayısı 1092 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Merhaba arkadaşlar;
1 hafta önce Ubuntu 18.04 sürümünü yükledim bilgisayarımı. Android studioyu kurdum. Fiziksel cihaz ile uygulama çalışıyor ama emulator yükleyip çalıştırınca
Alıntı
Emulator: Process finished with exit code 139 (interrupted by signal 11: SIGSEGV)
hatası almaktayım.

Emulator'ün log dosyası ise https://files.fm/u/cbuxze5p? linktedir.

Arattığımda çoğu çözümü denedim ama malesef çalışmadı.
- BIOS ta sanallaştırmaya izin verdim.
- Emulatoru software olarak çalıştırmaktayım.
- Ve diğer bir çok şeyi denedim.

Sadece deneyemediğim
Alıntı
cd ~/Development/Android/Sdk/emulator/lib64/
mv libstdc++ libstdc++.bak
oldu. Benim lib64 dosyamın içinde libstdc++ dosyası bulunmadığı için. Bundan kaynaklanıyor olabilir mi?

Daha önce böyle bir hata ile uğraşan ve çözen var mı?

« Yanıtla #1 : »
Şunu dene:
Kod: [Seç]
ln -sf /usr/lib64/libstdc++.so.6 ~/Development/Sdk/emulator/lib64/libstdc++.so.6

« Yanıtla #2 : »
Malesef yine aynı hatayı vermekte.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 19 Temmuz 2018 - 10:14:16
Yardım edebilecek biri yok mu?
« Son Düzenleme: 19 Temmuz 2018 - 10:14:16 Gönderen: fevziomurtekin »

« Yanıtla #3 : »
Aynı sorunu bende yaşamaktayım. İlk mesajda geçen çözümlerin yanında grafik kartı yazılımını baştan yükledim, farklı sanal cihazlar kurup denedim çözümü bulamadım.

« Yanıtla #4 : »
@bluntk Bende çözüm bulamadım hala. Elemantary OS dağıtımını yükledim. Onda da aynı hata devam ediyor.

« Yanıtla #5 : »
@bluntk Bende çözüm bulamadım hala. Elemantary OS dağıtımını yükledim. Onda da aynı hata devam ediyor.

Bana donanımsal bir hata gibi geldi. Ekran kartıyla ilgili olabilir ama onu da tamamen güncelledim. Şimdi böyle aptal bir şey yüzünden windowsa dönesimde yok ama uygulamayıda geliştirmem lazım çok can sıkıcı. Hatayı arattığımda çıkan tüm makaleleri okuyup çözümleri deniyorum ama daha fazla kaynakta kalmadı.

« Yanıtla #6 : »



Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : [time]05 Ekim 2018 - 01:05:00[/time]
@bluntk Bende çözüm bulamadım hala. Elemantary OS dağıtımını yükledim. Onda da aynı hata devam ediyor.

Bana donanımsal bir hata gibi geldi. Ekran kartıyla ilgili olabilir ama onu da tamamen güncelledim. Şimdi böyle aptal bir şey yüzünden windowsa dönesimde yok ama uygulamayıda geliştirmem lazım çok can sıkıcı. Hatayı arattığımda çıkan tüm makaleleri okuyup çözümleri deniyorum ama daha fazla kaynakta kalmadı.

Al benden de o kadar. Genymotion da olmuyor bende. Sende çalışıyor mu genymotion? Onu yükledim malesef olmadı.
Genymotion a yazdım. Virtualboxa yazdım olmadı.
Hiçbir dönüş alamadım. Bende sonuç çıkmadı.
Docker emulator kullanmaya başladım sende bir dene istersen cok performanslı bir şey değil ama.

« Yanıtla #7 : »



Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : [time]05 Ekim 2018 - 01:05:00[/time]
@bluntk Bende çözüm bulamadım hala. Elemantary OS dağıtımını yükledim. Onda da aynı hata devam ediyor.

Bana donanımsal bir hata gibi geldi. Ekran kartıyla ilgili olabilir ama onu da tamamen güncelledim. Şimdi böyle aptal bir şey yüzünden windowsa dönesimde yok ama uygulamayıda geliştirmem lazım çok can sıkıcı. Hatayı arattığımda çıkan tüm makaleleri okuyup çözümleri deniyorum ama daha fazla kaynakta kalmadı.

Al benden de o kadar. Genymotion da olmuyor bende. Sende çalışıyor mu genymotion? Onu yükledim malesef olmadı.
Genymotion a yazdım. Virtualboxa yazdım olmadı.
Hiçbir dönüş alamadım. Bende sonuç çıkmadı.
Docker emulator kullanmaya başladım sende bir dene istersen cok performanslı bir şey değil ama.

Diğerlerini denemedimde bana Android Studio lazım.

« Yanıtla #8 : »
Android Studio'nun emulatore getirdiği son güncellemesi ile Graphics=Automatic de emulator bende çalışmakta. İstersen bir daha dene.

« Yanıtla #9 : »
Arkadaşlar bende de aynı sorun var denemediğim şey kalmadı çözebildiniz mi?



Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 23 Kasım 2018 - 23:51:40
Android Studio'nun emulatore getirdiği son güncellemesi ile Graphics=Automatic de emulator bende çalışmakta. İstersen bir daha dene.
malesef olmadı
« Son Düzenleme: 23 Kasım 2018 - 23:51:40 Gönderen: hakanbakacak »

« Yanıtla #10 : »
Ben hala çözemedim. Sırf bu yüzden windowsa geçmeyi düşünüyorum.

« Yanıtla #11 : »
Arkadaşlar sorun hala çözülemedi sanırım. İşinizi görür mü bilmiyorum ama Pardus dağıtımında destek bölümünde aldığım ve uyguladığım cevap budur. Sorun düzeldi arkadaşlar bu şekilde.

Masaüstüne baslat.sh (baslat yerine istediğiniz bir isim yazabilirsiniz) dosyası oluşturup içerisine aşağıdaki kodu yazın ve kaydedin:

#!/bin/sh
LC_ALL=C XXXXX

Not: Buradaki XXXX olan yere dosyanın bulunduğu yol yazılacak. Örnek:
LC_ALL=C /opt/android-studio/bin/studio.sh

baslat.sh dosyasına çalıştırma izni verin:

sudo chmod +x baslat.sh

Şu an kullanıyorum sorun yok arkadaşlar.

 
« Son Düzenleme: 11 Ocak 2019 - 22:48:44 Gönderen: nerondes »

« Yanıtla #12 : »
Arkadaşlar sorun hala çözülemedi sanırım. İşinizi görür mü bilmiyorum ama Pardus dağıtımında destek bölümünde aldığım ve uyguladığım cevap budur. Sorun düzeldi arkadaşlar bu şekilde.

Masaüstüne baslat.sh (baslat yerine istediğiniz bir isim yazabilirsiniz) dosyası oluşturup içerisine aşağıdaki kodu yazın ve kaydedin:

#!/bin/sh
LC_ALL=C XXXXX

Not: Buradaki XXXX olan yere dosyanın bulunduğu yol yazılacak. Örnek:
LC_ALL=C /opt/android-studio/bin/studio.sh

baslat.sh dosyasına çalıştırma izni verin:

sudo chmod +x baslat.sh

Şu an kullanıyorum sorun yok arkadaşlar.

Ben denedim çözümü ancak sh dosyasını açtığımda metin düzenleyicide açılıyor.

« Yanıtla #13 : »


baslat.sh dosyasını android studionun kurulu olduğu dizindeki bin klasörünün içine atın.
örnek olarak bende bu dizin şu şekilde: /opt/android-studio/bin

İki yöntem var.
1. Yöntem de masa üstüne bir başlatıcı oluşturun.(windowstaki kısayol yani)

Baslatıcının  komut kısmına : ./baslat.sh
 
Çalışma dizini kısmına : androidstudio kurulu dizin/bin    yazın.
örnek olarak benim durumuma göre : /opt/android-studio/bin     

İsim kısmına ve simge kısmına istediğiniz isim ve simgeyi ekleyebilirsiniz.Kaydet deyin.Başlatıcıya tıkladığınızda android studio açılacak ve emülatörler kullanılır olacaktır.

2. yöntem ise zaten var olan başlatıcının komut kısmı ./studio.sh şeklindedir. Burayı ./baslat.sh olarak degistirin. Dizin kısmında yazan adresin  baslat.sh  dosyasını kopyaladığımız dizin olduğundan emin olun.
İsim kısmına ve simge kısmına istediğiniz isim ve simgeyi ekleyebilirsiniz.Kaydet deyin.Başlatıcıya tıkladığınızda android studio açılacak ve emülatörler kullanılır olacaktır.



« Yanıtla #14 : »


baslat.sh dosyasını android studionun kurulu olduğu dizindeki bin klasörünün içine atın.
örnek olarak bende bu dizin şu şekilde: /opt/android-studio/bin

İki yöntem var.
1. Yöntem de masa üstüne bir başlatıcı oluşturun.(windowstaki kısayol yani)

Baslatıcının  komut kısmına : ./baslat.sh
 
Çalışma dizini kısmına : androidstudio kurulu dizin/bin    yazın.
örnek olarak benim durumuma göre : /opt/android-studio/bin     

İsim kısmına ve simge kısmına istediğiniz isim ve simgeyi ekleyebilirsiniz.Kaydet deyin.Başlatıcıya tıkladığınızda android studio açılacak ve emülatörler kullanılır olacaktır.

2. yöntem ise zaten var olan başlatıcının komut kısmı ./studio.sh şeklindedir. Burayı ./baslat.sh olarak degistirin. Dizin kısmında yazan adresin  baslat.sh  dosyasını kopyaladığımız dizin olduğundan emin olun.
İsim kısmına ve simge kısmına istediğiniz isim ve simgeyi ekleyebilirsiniz.Kaydet deyin.Başlatıcıya tıkladığınızda android studio açılacak ve emülatörler kullanılır olacaktır.

Ben snapten yüklediğim için mi acaba böyle oldu anlamadım.

« Yanıtla #15 : »
Sorun snaptan yükleme ile alakalı değil. Android Studio güncellemelerinden sonra bu sorun oluştu.