Gönderen Konu: [Çözüldü] Amd r7 240 ekran kartı için doğru sürücü kurulumu yapamıyorum.  (Okunma sayısı 531 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

xf86-video-amdgpu paketini kurduğum halde çekirdek radeon sürücüsünü kullanıyor ve lspci -nnk | egrep "VGA|3D|Display" -A2 komutu radeon r7 240 olan kartımı Radeon HD 7730/8730 olarak gösteriyor. Bu haliyle kullanırken tek sıkıntım yüksek fan sesi.
https://forum.ubuntu-tr.net/index.php?topic=55265.0 adresinde aynı grafik kart işlemcisini kullananın lspci -nnk | egrep "VGA|3D|Display" -A2 çıktısı
Kod: [Seç]
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Oland PRO [Radeon R7 240/340] [1002:6613] (rev 87)
Subsystem: Micro-Star International Co., Ltd. [MSI] Oland PRO [Radeon R7 240/340] [1462:8094]
Kernel driver in use: amdgpu

Kendi makinemin çıktıları:
lspci -nnk | egrep "VGA|3D|Display" -A2
Kod: [Seç]
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde LE [Radeon HD 7730/8730] [1002:6837]
Subsystem: Micro-Star International Co., Ltd. [MSI] Cape Verde LE [Radeon HD 7730/8730] [1462:809c]
Kernel driver in use: radeon
xorg.conf dosyası mevcut değil oluşturunca x sunucusu açılmıyor.
updatedb && locate xorg.conf
Kod: [Seç]
/etc/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-amdgpu.conf
/usr/share/X11/xorg.conf.d/10-quirks.conf
/usr/share/X11/xorg.conf.d/40-libinput.conf
cat /usr/share/X11/xorg.conf.d/10-amdgpu.conf
Kod: [Seç]
Section "OutputClass"
Identifier "AMDgpu"
MatchDriver "amdgpu"
Driver "amdgpu"
EndSection
lsb_release -a
Kod: [Seç]
LSB Version: 1.4
Distributor ID: Arch
Description: Arch Linux
Release: rolling
Codename: n/a

glxinfo | grep render
Kod: [Seç]
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: AMD CAPE VERDE (DRM 2.50.0 / 4.15.8-1-ARCH, LLVM 5.0.1)
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
xrandr
Kod: [Seç]
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
HDMI-1 disconnected primary (normal left inverted right x axis y axis)
DVI-D-1 disconnected (normal left inverted right x axis y axis)
VGA-1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      59.79*+
   1280x720      59.99    59.86    59.74 
   1024x768      60.04    75.03    72.00    70.07    60.00 
   960x720       60.00 
   928x696       75.00    60.05 
   896x672       75.05    60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   832x624       74.55 
   960x540       59.96    59.99    59.63    59.82 
   800x600       75.00    70.00    65.00    60.00    72.19    75.00    60.32    56.25 
   840x525       60.01    59.88 
   864x486       59.92    59.57 
   700x525       74.76    59.98 
   800x450       59.95    59.82 
   640x512       75.02    60.02 
   700x450       59.96    59.88 
   640x480       60.00    75.00    72.81    75.00    66.67    59.94 
   720x405       59.51    58.99 
   720x400       70.08 
   684x384       59.88    59.85 
   640x400       59.88    59.98 
   576x432       75.00 
   640x360       59.86    59.83    59.84    59.32 
   512x384       75.03    70.07    60.00 
   512x288       60.00    59.92 
   416x312       74.66 
   480x270       59.63    59.82 
   400x300       72.19    75.12    60.32    56.34 
   432x243       59.92    59.57 
   320x240       72.81    75.00    60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32 

sudo pacman -Q | egrep "amdgpu|fglrx|nvidia|bumblebee|nvidia-prime"
Kod: [Seç]
xf86-video-amdgpu 18.0.0-1
insmod amdgpu
Kod: [Seç]
insmod: ERROR: could not load module amdgpu: No such file or directory
*amdgpu-pro sürücüsü archlinux için resmi olarak mevcut değil. aur deposundakiler artık kurulamıyor.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : [time]12 Mart 2018 - 23:25:40[/time]
Kıt ingilizcemle zorda olsa çözümü bulabildim.
https://www.x.org/wiki/RadeonFeature/ adresinde r7 240 ve 7730/8730 için Southern Islands yazıyor.
lspci -nnk | egrep "VGA|3D|Display" -A2 çıktısında Radeon HD 7730/8730 yazmasının önemli olmadığını anladım.

arch linux için 4.13 çekirdek sürümü sonrası ve grub2 kullananlar için çözüm:
/etc/default/grub dosyasında GRUB_CMDLINE_LINUX_DEFAULT= kısmına
Kod: [Seç]
amdgpu.si_support=1 radeon.si_support=0 ekleyip
Kod: [Seç]
grub-mkconfig -o /boot/grub/grub.cfg komutunu çalıştırmak.

 
« Son Düzenleme: 12 Mart 2018 - 23:26:20 Gönderen: mimiksiz »