Gönderen Konu: ubuntu 17.10 ses kartını tanımıyor  (Okunma sayısı 817 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Kod: [Seç]
vgs@vgs-N360:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful
vgs@vgs-N360:~$ lspci | grep Audio
vgs@vgs-N360:~$ lspci | grep Audio
vgs@vgs-N360:~$ sudo lspci | grep Audio
[sudo] password for vgs:
vgs@vgs-N360:~$ grep "Codec:" /proc/asound/card*/codec*
grep: /proc/asound/card*/codec*: Böyle bir dosya ya da dizin yok
vgs@vgs-N360:~$ lsmod | grep snd
snd_soc_sst_bytcr_rt5640    24576  0
snd_soc_rt5670        131072  0
snd_soc_rt5645        147456  0
snd_soc_rt5640        118784  1 snd_soc_sst_bytcr_rt5640
snd_soc_tlv320aic31xx    49152  0
snd_intel_sst_acpi     16384  1
snd_intel_sst_core     77824  1 snd_intel_sst_acpi
snd_soc_sst_atom_hifi2_platform   102400  1 snd_intel_sst_core
snd_soc_sst_match      16384  2 snd_soc_sst_bytcr_rt5640,snd_intel_sst_acpi
snd_soc_rl6231         16384  3 snd_soc_rt5670,snd_soc_rt5640,snd_soc_rt5645
snd_soc_core          229376  6 snd_soc_sst_bytcr_rt5640,snd_soc_rt5670,snd_soc_rt5640,snd_soc_tlv320aic31xx,snd_soc_sst_atom_hifi2_platform,snd_soc_rt5645
snd_hdmi_lpe_audio     24576  3
snd_compress           20480  1 snd_soc_core
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm                98304  10 snd_soc_sst_bytcr_rt5640,snd_soc_rt5670,snd_hdmi_lpe_audio,snd_pcm_dmaengine,snd_soc_rt5640,snd_soc_tlv320aic31xx,snd_soc_sst_atom_hifi2_platform,snd_soc_rt5645,snd_soc_core
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  14 snd_compress,snd_seq,snd_hdmi_lpe_audio,snd_timer,snd_soc_sst_atom_hifi2_platform,snd_rawmidi,snd_seq_device,snd_soc_core,snd_pcm
soundcore              16384  1 snd

Merhaba ubuntu 17.10 kurdum ses çıkmıyo diğerdonanımlar dokunmatk hariç çalışıyor. bilgisayarım 2si bir arada laptop.
Birkaç yere baktım * bir şey bulamadım..

« Yanıtla #1 : »
https://github.com/plbossart/UCM
UCM dizinini indiriyoruz ve açıp Dizin içine girin ve Uçbirimi orada açın..


Kod: [Seç]
sudo cp -rf /byt-rt5640 /usr/share/alsa/ucmbyt-rt5640 dizinini  /usr/share/alsa/ucm içerisine kopyalıyoruz.


Kod: [Seç]
sudo apt-get install alsa-utilsalsa-utils paketi kurulu değilse kuruyoruz.


Kod: [Seç]
sudo alsactl storealsa ayar dosyası oluştuyoruz. (/varlib/alsa/asound.state adına dosya oluyor.)

Kod: [Seç]
pulseaudio -kpulseaudio tekrar başlatılıyor.



Bundan sonrasında hapörler çalışır ama kulaklık sesi genelde kapalı olur.
Bu yüzden kulaklık kullanıyorsan amixer/alsamixer ile açmayı deneyebilir ya da yazılmış bir script ile yapabilirsin.

« Son Düzenleme: 22 Ekim 2017 - 11:44:42 Gönderen: serk »

« Yanıtla #2 : »
Bir deneyim kardeş sağolasın..

GM 5 d cihazımdan Tapatalk kullanılarak gönderildi




Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 22 Ekim 2017 - 14:05:05
https://github.com/plbossart/UCM
UCM dizinini indiriyoruz ve açıp Dizin içine girin ve Uçbirimi orada açın..


Kod: [Seç]
sudo cp -rf /byt-rt5640 /usr/share/alsa/ucmbyt-rt5640 dizinini  /usr/share/alsa/ucm içerisine kopyalıyoruz.


Kod: [Seç]
sudo apt-get install alsa-utilsalsa-utils paketi kurulu değilse kuruyoruz.


Kod: [Seç]
sudo alsactl storealsa ayar dosyası oluştuyoruz. (/varlib/alsa/asound.state adına dosya oluyor.)

Kod: [Seç]
pulseaudio -kpulseaudio tekrar başlatılıyor.



Bundan sonrasında hapörler çalışır ama kulaklık sesi genelde kapalı olur.
Bu yüzden kulaklık kullanıyorsan amixer/alsamixer ile açmayı deneyebilir ya da yazılmış bir script ile yapabilirsin.
kardes yaptim ama olmadi degisen bir sey yok ses calismadi asagidaki hatalari verdi.
Kod: [Seç]
vgs@vgs-N360:~/İndirilenler/UCM-stable$ sudo cp -rf /byt-rt5640 /usr/share/alsa/ucm
[sudo] password for vgs:
cp: '/byt-rt5640' durumlanamadı: Böyle bir dosya ya da dizin yok
vgs@vgs-N360:~/İndirilenler/UCM-stable$ ls
bytcr-nocodec  bytcr-rt5640  bytcr-rt5651  byt-rt5640
vgs@vgs-N360:~/İndirilenler/UCM-stable$ sudo apt-get install alsa-utils
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
alsa-utils zaten en yeni sürümde (1.1.3-1ubuntu1).
Aşağıdaki paket otomatik olarak kurulmuş ve artık bu pakete gerek duyulmuyor:
  iucode-tool
Bu paketi kaldırmak için 'sudo apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
N: '/etc/apt/sources.list.d/' dizinindeki 'libreoffice-ubuntu-ppa-artful.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
Devam etmek istiyor musunuz? [E/h] e
Ayarlanıyor: oem-audio-hda-daily-dkms (0.201710180117~ubuntu17.10.1) ...
Removing old oem-audio-hda-daily-0.201710180117~ubuntu17.10.1 DKMS files...

------------------------------
Deleting module version: 0.201710180117~ubuntu17.10.1
completely from the DKMS tree.
------------------------------
Done.
Loading new oem-audio-hda-daily-0.201710180117~ubuntu17.10.1 DKMS files...
First Installation: checking all kernels...
/usr/share/oem-audio-hda-daily-dkms/postinst: 36: /usr/share/oem-audio-hda-daily-dkms/postinst: 4.13.0-16-generic=4.13.0: not found
dpkg: oem-audio-hda-daily-dkms paketi işlenirken sorun yaşandı (--configure):
 alt süreç post-installation betiği kuruldu 127 çıkış kodu ile sona erdi
İşleme sırasında hatalarla karşılaşıldı:
 oem-audio-hda-daily-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
vgs@vgs-N360:~/İndirilenler/UCM-stable$ sudo alsactl store
vgs@vgs-N360:~/İndirilenler/UCM-stable$ pulseaudio -k
vgs@vgs-N360:~/İndirilenler/UCM-stable$
ayrica ses aygiti asagidaki resimdeki gibi gorunuyor
« Son Düzenleme: 22 Ekim 2017 - 14:05:05 Gönderen: volkanadana »

« Yanıtla #3 : »
Tüm işlemleri hatasız yaptımancak son işlemde şöyle bir hata verdi.
Kod: [Seç]
vgs@vgs-N360:~$ pulseaudio -k
E: [pulseaudio] main.c: Artalan işlem durdurulamadı: Böyle bir dosya ya da dizin yok

« Yanıtla #4 : »
Kod: [Seç]
alsamixer
açılan pencerede f6 yapıp defauld olup olmadığını bir kontrol edermisin ?

« Yanıtla #5 : »
dediğinizi defalarca yaptım..ama nasile, ses kartını reimdeki gibi görüyor.. f6 yapınca böyle görünüyor.



Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 30 Ekim 2017 - 14:01:59
bşr ara byt-rt5640 ses kartı cihazını gördü bilgisayar ama default olarak o ses kartını seçemedim alsamixer den onu seçince hata verdi.. nerede yanlış yapıyorum acaba..

« Yanıtla #6 : »
ses kartı modelini ögrenin:
1.
Kod: [Seç]
cat /proc/asound/card0/codec* | grep Codec
2.alsa konfigürasyon dosyasını açın:
Kod: [Seç]
sudo nano /etc/modprobe.d/alsa-base.confses kartı modelini aşagıdaki satırın sonuna yazıp dosyanın en altına ekleyin.
Kod: [Seç]
options snd-hda-intel model=seskartınınmodeli
3.kaydedip çıktıktan sora
Kod: [Seç]
sudo alsa force-reload
veya

Kod: [Seç]
sudo reboot
çözülmediği takdirde
https://help.ubuntu.com/community/HdaIntelSoundHowto

« Yanıtla #7 : »
f6 ile  açınca yön tuşları ile varsayılan yapıp ok diyerek deneyin.

« Yanıtla #8 : »
vgs@vgs-N360:~$ cat /proc/asound/card0/codec* | grep Codec
cat: '/proc/asound/card0/codec*': Böyle bir dosya ya da dizin yok

bu hatayı veriyor..


« Yanıtla #9 : »
peki Linux Mint 18,2 XFCE'nin hoparlör sembolü kaybolunca ne yapılır?

« Yanıtla #10 : »
vgs@vgs-N360:~$ cat /proc/asound/card0/codec* | grep Codec
cat: '/proc/asound/card0/codec*': Böyle bir dosya ya da dizin yok

bu hatayı veriyor..
Cihaz neydi tabletmi?
Bahsi geçen byt-rt5640 sorunlu bir donanım olduğu belirtilmiş.
Aşağıdaki *bağlantıda 5640 ilgili konfigurasyon dosyaları mevcut deneyin.

https://github.com/plbossart/UCM

« Yanıtla #11 : »
vgs@vgs-N360:~$ cat /proc/asound/card0/codec* | grep Codec
cat: '/proc/asound/card0/codec*': Böyle bir dosya ya da dizin yok

bu hatayı veriyor..
Cihaz neydi tabletmi?
Bahsi geçen byt-rt5640 sorunlu bir donanım olduğu belirtilmiş.
Aşağıdaki *bağlantıda 5640 ilgili konfigurasyon dosyaları mevcut deneyin.

https://github.com/plbossart/UCM
Evet ikisi bir arada casper

GM 5 d cihazımdan Tapatalk kullanılarak gönderildi