Gönderen Konu: Debian 9 KDE F Klavye Sorunu  (Okunma sayısı 1103 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Merhaba.

Eskiden diğer dağıtımlar için alt başlıklar vardı ama şimdi kaldırılmış. Debian Forum'a yine giriş yapılamıyor; acaba sorunuma yardımcı olabilir misiniz?

Debian 9.01 (64) KDE kurdum. Kurulum sırasında kabul ettiği, kullanmama izin verdiği F klavyeyi sistem üzerinde bulamadım. Hiçbir ayarda F klavye düzeneği yok. Firefox'ta ve masaüstünde kullanılabiliyor ama root olmamı gerektirecek işlemler için açılan parola pencerelerinde başka bir düzen var. Saatlerce uğraştım, bir kere bile root olamadım. Harfleri Q düzenine göre girdim, tersini denedim, olmadı. Belki kurulum sırasında yanlış girmişimdir ya da büyük harf tuşu açık kalmıştır diye peşpeşe üç kurulum yaptım, sonuç değişmedi.

F klavye düzenini sisteme yükleyebilir miyim ya da yapabileceğim başka bir şey var mı?

Teşekkürler, saygılarımla.
:)  :)  :)

« Yanıtla #1 : »
Sadece terminal için sanırım. Öncelikle şunlara bakabilir miyiz?
Kod: [Seç]
localectl status
localectl list-keymaps|grep -i '^tr'
cat /etc/vconsole.conf

Root için şunu bir dene,
Kod: [Seç]
loadkeys trf
sudo passwd root

« Yanıtla #2 : »
İlginiz için teşekkür ederim. Şu çıktıları verdi:

hadon@debian:~$ localectl status
   System Locale: LANG=tr_TR.UTF-8
       VC Keymap: n/a
      X11 Layout: tr
       X11 Model: pc105
     X11 Variant: f
hadon@debian:~$ localectl list-keymaps|grep -i '^tr'
Couldn't find any console keymaps.
hadon@debian:~$ cat /etc/vconsole.conf
cat: /etc/vconsole.conf: Böyle bir dosya ya da dizin yok
hadon@debian:~$ loadkeys trf
Couldn't get a file descriptor referring to the console
hadon@debian:~$ sudo passwd root

Yerel Sistem Yöneticisinden olağan öğütleri aldığınıza güveniyoruz.
Bunları genellikle aşağıdaki üç şeyle özetleyebiliriz:

    #1) Diğer kişilerin özel hayatına saygı gösterin.
    #2) Bir yazmadan önce iki kere düşünün.
    #3) Büyük gücün büyük bir sorumluluk getirdiğini unutmayın.

[sudo] password for hadon:
hadon sudoers dosyası içinde değil.  Bu olay rapor edilecek.
hadon@debian:~$

:)  :)  :)

« Yanıtla #3 : »
Çıktıları kod etiketi içine alabilirmisin? Bu şekilde okunaklı olmuyor.
Şunu bir denememiz gerekecek,
Kod: [Seç]
echo 'KEYMAP=trf' >/etc/vconsole.confFakat sudoers içine kullanıcıyı tanımlamak gerekiyor önce. Bunun içinde root olabilmen gerekiyor ama o konuda da engelimiz var. Tam bir çıkmaza girdik ;-)
Debian da kurulum CD si üzerinden chroot ortamına geçiş yapabilir misin? (Nasıl yapacağın veya yapılabilirliği hakkında fikrim yok. Araştırırsın.)
Bunu yapabilirsen ister yukarda verdiğim komutu yürüterek konsol klavye tipini ayarlarsın,
Kod: [Seç]
echo 'KEYMAP=trf' >/etc/vconsole.confİstersen /etc/sudoers dosyasına şu eklemeyi yaparak sudo izni alabilirsin.
Kod: [Seç]
nano -t /etc/sudoers ## sudoers dosyası açılacak
%wheel ALL=(ALL) ALL  ## dosyaya eklenecek
## kaydedip çıkmak için F2 tuşu

(bu durumda yukardaki işlem mevcut ortamdan yapılabilir.)
Kod: [Seç]
sudo bash -c 'echo "KEYMAP=trf" >/etc/vconsole.conf'
« Son Düzenleme: 05 Temmuz 2017 - 22:20:07 Gönderen: mhmtkrktr »

« Yanıtla #4 : »
Kusura bakmayın kod etiketine nasıl alındığını unuttum.

İşte verdiğiniz ilk komutun çıktısı:

hadon@debian:~$ echo 'KEYMAP=trf' >/etc/vconsole.conf
bash: /etc/vconsole.conf: Erişim engellendi
hadon@debian:~$

Diğerinde dosya açılıyor ama içine nasıl yazacağımı bilemediğim için bir şey olmuyor. Kurulum CD'si ile işlem yapmayı gözüm yemiyor. İnternet'te araştırma yapmak içinse İngilizcem yeterli değil. Galiba bütün bunlar benim Debian 9 KDE kullanmamam gerektiğini anlatıyor.  :)  Kurulumu Q klavye ile yapsam belki sorun çıkmaz ama daktilodan başlayarak 30 senedir F klavye kullandığım için onu da istemiyorum.

İlginiz için teşekkür ederim.
:)  :)  :)

« Yanıtla #5 : »
https://forum.ubuntu-tr.net/index.php?topic=14283.0

Erişim engellendi diyor çünkü başında sudo olmalı. Ben root hesabında yapabileceğini hesap ederek o şekilde verdim. Normal kullanıcı olarak aynı komutu şu şekilde verebilirsin.

Kod: [Seç]
sudo bash -c 'echo "KEYMAP=trf" >/etc/vconsole.conf'
Ancak orada da bir sorun olduğu görünüyor. Senin kullanıcının sudo yetkisi yok. Bunların (en azından birinin) kurulum aşamasında yapılması gerekiyordu. Chroot dediğim ortam seni tekrardan kurulum ortamına sokmaya yarar. Korkulacak veya zor bir durum değil.
Fakat yinede ben bu işlerden uzak durayım dersen, belkide kullanmak istediğin sistem Debian olmayabilir. Şunu da belirteyim, konsol klavye tipi masaüstüne bağlı değil. Yani KDE bu konudan sorumlu değil.
Devam etmek istiyorsan Debian chroot işlemine bakabilirim, başka bir ortam istersen ona da geçebilirsin.

« Yanıtla #6 : »
Eğer zahmet olmayacaksa, Debian'da chroot işlemi konusunda yönlendirebilirseniz çok mutlu olurum.
:)  :)  :)

« Yanıtla #7 : »
Kurulum sırasında "root" kısmında şifre girdiniz sanırım ? Bildiğim kadarıyla, eğer o kısma hiç bir karakter girmeyip devam edip, kullanıcı şifresi girince, o kullanıcıyı otomatik olarak sudo grubuna alır.

"su" yazıp root a düşmeyi dener misin

« Yanıtla #8 : »
su yazarak root olmayı denedim, olmadı.

Kurulumda, root şifresini de kullanıcı şifresini de nerede istediyse orada girdim. Üst üste üç kez kurulum yaptığım için yanlış girme olasılığı sıfır. 6.0 sürümünden beri Debian kullandığım için, kurulumda benden kaynaklı bir hata olmadığından eminim.

Aslında, root şifresini neden kabul etmediğinin mantıklı bir açıklaması yok. Çünkü, örneğin konsolda f klavye ile sorunsuzca yazıyorum,  şifreyi girdiğimde kabul etmiyor. Sorunun klavye düzeninden kaynaklandığını ben tahmin üzerine söyledim. Belki de farklı bir durum vardır. Bu mesajları da aynı Debian üzerinde, aynı klavye ile yazıyorum. Sorun sadece root olmamı gerektiren durumlarda ortaya çıkıyor. Giriş ekranında kullanıcı şifresinde de problem yok. 
:)  :)  :)

« Yanıtla #9 : »
Ubuntu için bir anlatım buldum. Farklı olacağını sanmıyorum. https://help.ubuntu.com/community/LiveCdRecovery

Senin yapacağın işleme göre sıralayayım.
Live cd ile sistem başlatılacak.
İnstall, graphical install vs yazan ekranda CTRL+ALT+ F3 ile tty konsoluna geçiş yapılacak.
NOT: kullanıcı adı ve sudo için şifre isterse şunu denersin; https://stackoverflow.com/questions/30842216/debian-8-live-cd-what-is-the-standard-login-and-password
Kod: [Seç]
login : Debian Live User
password : live

Kod: [Seç]
loadkeys trf ## hata verebilir, önemli değil

sudo fdisk -l ## kök bölümünü (filesystem) tesbit etmek için. Değerleri aynı ise şu komut daha belirleyici olacaktır.
sudo fdisk -l|awk '/filesystem/{print $1}'

sudo mount ??? /mnt  ## soru işareti olan yere, yukarda bulduğumuz bölümün etiketi girilecek. örn: /dev/sda1 gibi
sudo chroot /mnt  ## bu noktadan sonra komutların başında sudo olmayabilir. hata verirse sudo yazmadan denersin.

sudo nano -t /etc/sudoers
### açılan içerikte root ALL=(ALL) ALL satırı bulunacak ve altına şu ilave edilecek
%wheel ALL=(ALL) ALL
## kaydedip çıkmak için F2 tuşu

sudo bash -c 'echo "KEYMAP=trf" >/etc/vconsole.conf'
### sudo ile hata alırsan şu şekilde kullanırsın,
echo "KEYMAP=trf" >/etc/vconsole.conf

## CTRL + D ile çıkış yapılacak
sudo umount /mnt
reboot

reboot dan sonra CD yi çıkart ki, tekrar live olarak başlamasın. ;-)

Bu yazdıklarımın hiçbirini denemedim ve deneme şansım şuan için yok. Tamamen olasılık üzerinden yazıyorum. Fakat şunu söyleyebilirim, sadece söylediğim gibi devam edersen, mevcut sistemine zarar verme durumu söz konusu değil. Olmazsa bile sadece denemiş olursun.

« Yanıtla #10 : »
Olmadı maalesef... kurulum seçimi ekranında CTRL+ALT+F3 kombinasyonunun hiçbir etkisi olmadı; tty konsolu açılmadı. Birkaç defa denedim. Hattâ Debian 8 DVD'si de aynı şekilde işe yaramadı.
:)  :)  :)

« Yanıtla #11 : »
Oluyor ama anlattığımdan biraz daha farklı. ;-)
Olmuyor deyince, şimdi Debian-9 xfce cd'sini indirip denedim. Farklı bir yöntemi vardır belki ama fazla karıştırmadan ben sana izlediğim yolu anlatayım. Sende aynı şekilde devam edersin.

Not: Cd içerisinde fdisk gibi, disk bölümlerine ayrıntılı bakabileceğin komutlar yok. list-devices partition komutu bölümleri gösteriyor ama neyin hangi bölüm olduğunu söylemiyor. Bu sebeple bu işleme geçmeden önce, mevcut çalışan sisteminden dosya sisteminin hangi bölüme kurulduğunu kontrol etmeni ve not almanı öneririm. Daha önce komutunu vermiştim.
sudo fdisk -l
veya
sudo fdisk -l|awk '/filesystem/{print $1}'
şeklinde bakabilirsin.

Live cd ile başlat,
Başlangış seçeneklerinden, advanced options > Graphical rescue mode seçeneği ile devam et.
Dil / Bölge / Klavye seçimini kendine göre yap.
Ağ yapılandırma, makina adı falan fisman oraları geç,
Kurtarma kipine gir diye bir pencere açılacak. ( Altında disk bölümlerinin listelendiği bir pencere. )
Bu pencere geldiğinde (herhangi bir işlem yapmadan) Ctrl + Alt + F3 tuşu ile konsola geçiş yap.
Konsol kullanımına geçilsin mi gibisinden bir soru soruyor. Enter ile kullanıma geç. Ardından,

Kod: [Seç]
mouth /dev/sd?? /mnt      ## sd?? = sistemin kurulduğu bölüm. örn: /dev/sda1
chroot /mnt

nano -t /etc/sudoers
###    açılan içerikte root ALL=(ALL) ALL satırı bulunacak ve altına şu ilave edilecek
%wheel ALL=(ALL) ALL
##    F2 ile dosyadan çıkış yap

echo "KEYMAP=trf" >/etc/vconsole.conf

##    Ctrl + D ile chroot dan çıkış yap
umouth /mnt
reboot

Sistem normal açıldığında sudo ile işlem yapmayı  ve konsol klavye biçimini denersin.

 

« Yanıtla #12 : »
İlginiz ve sabrınız için çok teşekkür ediyorum.

Kurulum yaptığım CD ile Live CD farklı mı acaba?

Ben ayrıca bir Live CD indirmedim, kurulum yaptığımla denedim ve gene sonuç alamadım. Şu an bahsettiğim canlı CD üzerinden yazıyorum. Bu CD ile başlattığınızda menüde kurtarma seçenekleri veya başkaları çıkmıyor; sistem açılıyor.

İlginç olan şurası ki bu şekilde kullandığınızda hiçbir sıkıntı yok. Sistemi doğrudan f klavye olarak ayarlayabiliyorsunuz; seçenekler arasında Türkçe f klavye düzeni de var. Ayrıca diskimdeki diğer bölümlere ve hatta Debian bölümüne de sorunsuzca bağlanabiliyor.

Aklıma farklı bir şey geldi: Bilgisayarımda Debian dışında bir Win7 ve bir de Pisi Linux bölümü var. Pisi Linux üzerinden denediğimde Debian bölümüne ulaşıp işlem yapabildiğimi gördüm. Acaba bu sudoers dosyasını (veya gereken başka dosyaları) Pisi Linux üzerinden root olarak ulaşıp yapamaz mıyız?

Saygılarımla.

:)  :)  :)

« Yanıtla #13 : »
Farklı olabilir. Benim çalıştırdığım CD üzerinde Live çalıştıracak bir bölüm yoktu. Söylediğim gibi Debian bildiğim bir dağıtım değil.
Ben şurada ki xfce sürümünü indirmiştim. https://cdimage.debian.org/debian-cd/current/amd64/bt-cd/
Şu videonun 1:00 daki gibi bir menü ile başladı. https://www.youtube.com/watch?v=SGdwMVxQr1Q

İşlemleri Pisi üzerinden de yapabilirsin. Yapılacak işlem, yetkili kullanıcı olarak dosya düzenleme olduğu için, erişim sağlayabildiğin her sistemle olur. Sadece yol farkı olacak.
Pisi üzerinden, Debian'ın kurulu olduğu bölüme gider, etc/sudoers dosyasına gerekli eklemeyi yapabilirsin. Debian üzerinde ki kullanıcıda sudo yetkisine sahip olunca, ikinci işlemi Debian üzerinden yapabilirsin.
Kod: [Seç]
sudo bash -c 'echo "KEYMAP=trf" >/etc/vconsole.conf'

« Yanıtla #14 : »
Debian'da etc/sudoers.d içinde Read Me dosyası var; eklemeyi buna değil, bir sudoers dosyasına yapmamız gerekiyor galiba. Öyle bir dosya olmadığı için onu ben mi oluşturmalıyım?

Read Me dosyası içeriği şöyle:

#
# As of Debian version 1.7.2p1-1, the default /etc/sudoers file created on
# installation of the package now includes the directive:
#
#    #includedir /etc/sudoers.d
#
# This will cause sudo to read and parse any files in the /etc/sudoers.d
# directory that do not end in '~' or contain a '.' character.
#
# Note that there must be at least one file in the sudoers.d directory (this
# one will do), and all files in this directory should be mode 0440.
#
# Note also, that because sudoers contents can vary widely, no attempt is
# made to add this directive to existing sudoers files on upgrade.  Feel free
# to add the above directive to the end of your /etc/sudoers file to enable
# this functionality for existing installations if you wish!
#
# Finally, please note that using the visudo command is the recommended way
# to update sudoers content, since it protects against many failure modes.
# See the man page for visudo for more information.
#
:)  :)  :)

« Yanıtla #15 : »
Aşağıdaki komutu uçbirimde çalıştırınca sorun çözülüyorsa,

Kod: [Seç]
setxkbmap tr f
bu komutu başlangıç uygulamalarına ekleyerek bu sorunun etrafından dolaşabilirsin.

« Yanıtla #16 : »
Bu da olmadı. Komut olumlu, olumsuz herhangi bir çıktı vermeden tamamlandı ama işe yaramadı.

Root şifresini de, kullanıcı şifresini de yazamıyorum. Klavye çalışmaz hale geliyor; tuşlar o küçük pencerelere yazmıyor. Bir metin belgesi oluşturuyorum. Onun içinde şifreyi yazıp, kopyaladıktan sonra şifre isteyen pencereye giriyorum, kabul etmiyor. Bu yüzden, Debian gibi her işlem için şifre isteyen bir dağıtımda hiçbir iş yapamıyorum Ne uygulama kurabiliyorum, ne diğer disklere erişebiliyorum. :(
:)  :)  :)

« Yanıtla #17 : »
Özel mesajdan bildirim yollamıştım. Kontrol et istersen.

« Yanıtla #18 : »
Yukarıda çokça yazılıp çizilmiş ve uğraşılmış bu durumda benim verdiğim cevap biraz  aptalca basit olabilir işe yaramazsa bu nedenle şimdiden özür dileyim.
Plasma sistem ayarlarında "Girdi Aygıtları"nda "Klavye" sekmesinden "Düzenler" sekmesinde orta kısımda "Düzenleri yapılandır" kutucuğunu işaretlediğinizde şu şekilde ayarlanabiliyor.


« Yanıtla #19 : »
Şuan için asıl sorun sudo yetkisi oluyor sanırım. Bu çözülse diğeri kolay aslında.

« Yanıtla #20 : »
Şuan için asıl sorun sudo yetkisi oluyor sanırım. Bu çözülse diğeri kolay aslında.
Evet, asıl sorun bu!

@Burak Öztürk İşaret ettiğiniz şeyi zaten yapmıştım. Sorun kendini orada da gösteriyor: Kurulumu en baştan F klavye olarak yaptığım halde, sistemimde, oradaki menüde F klavye çıkmıyor. Oysa, kurulumu yaptığım DVD'yi Live CD olarak kullandığımda, menüde F görülüyor ve seçilebiliyor.

@mhmtkrktr Pisi üzerinde Teamviewer kurulabilir mi bilmiyorum, birazdan geçip bakarım. Ancak size önce şu bilgiyi vermem lazım. Debian'daki sudoers dosyasını buldum ve Pisi üzerinden yetkili olarak ulaşıp istediğiniz şekilde düzenledim. Sorunu bu da çözmedi.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 10 Temmuz 2017 - 18:57:41
Sorunumu çözebilmek için harika bir sabır içinde uğraşan dostlarıma çok teşekkür ediyorum. Sizin gibilerin varlığı insana mutluluk veriyor.

Problemi çözemedim ama etrafından dolaştım. Debian 9.0 DVD'sini indirip yeni kurulum yaptım. Masaüstlerini seçerken DE KDE ve Cinnamon'u işaretledim. Bunu iyi ki yapmışım; sadece KDE kursam aynı sorunu yine yaşayacakmışım. Çünkü anladım ki sorun KDE masaüstünde. KDE üzerinde F klavye düzeni yine görünmüyor, şifreler yine girilemiyor, disklere yine bağlanılamıyor. Ama Cinnamon'da hiçbir sıkıntı yok. Şu an Cinnamon masaüstünde F klavye seçili olarak sistemi kullanıyorum.

Sağolun, varolun.

« Son Düzenleme: 10 Temmuz 2017 - 18:57:41 Gönderen: hadon »
:)  :)  :)

« Yanıtla #21 : »
İlginç bir sorun ve çözüm olmuş ama çözülmüşse fazla kurcalamanın da gereği yok. Geçmiş olsun diyelim o zaman. ;-)