Gönderen Konu: Git Hub push problem  (Okunma sayısı 280 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Merhabalar arkadaşlar ubuntu üzerinden git kullanarak oluşturduğum repositoryi pushlamak istedim fakat şöyle bir hata ile karşılaştım yardımcı olursanız sevinirim.
Kod: [Seç]
admiralkheir@tugay-TWH:~/deneme$ git remote add origin git@github.com:Admiralkheir/deneme.git
admiralkheir@tugay-TWH:~/deneme$ git push origin master
/etc/ssh/ssh_config: line 55: Bad configuration option: gssapIauthentication
/etc/ssh/ssh_config: line 56: Bad configuration option: gssapIdelegatecredentials
/etc/ssh/ssh_config: terminating, 2 bad configuration options
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

« Yanıtla #1 : »
@admiralkheir
Kod: [Seç]
git remote set-url origin git@XXXXXXXXXXXX

« Yanıtla #2 : »
İkili doğrulama güvenlik sistemini mi kullanıyorsunuz?

« Yanıtla #3 : »
OpenSSH'ın 7.1p1 sürümünde mevcut olan bir hatadan[1] kaynaklanmakta. Hata için Launchpad'de bir hata kaydı açmıştım[1]. Bu[2] bağlantıda da OpenSSH böcek takip sistemine açtığım hata kaydı bulunmakta. Sorun OpenSSH'ın 7.4p1-5 sürümünde geçici olarak giderildi. İleride bu hatanın kaynağını daha düzgün bir şekilde çözmeye çalışacaklar, inşallah.

Geçici çözüm:
Kod: [Seç]
LC_ALL=C git ...

[1] https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1638338
[2] https://bugzilla.mindrot.org/show_bug.cgi?id=2643

« Yanıtla #4 : »
OpenSSH'ın 7.1p1 sürümünde mevcut olan bir hatadan[1] kaynaklanmakta. Hata için Launchpad'de bir hata kaydı açmıştım[1]. Bu[2] bağlantıda da OpenSSH böcek takip sistemine açtığım hata kaydı bulunmakta. Sorun OpenSSH'ın 7.4p1-5 sürümünde geçici olarak giderildi. İleride bu hatanın kaynağını daha düzgün bir şekilde çözmeye çalışacaklar, inşallah.

Geçici çözüm:
Kod: [Seç]
LC_ALL=C git ...

[1] https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/1638338
[2] https://bugzilla.mindrot.org/show_bug.cgi?id=2643
öncelikle uğraşların için teşekkürler açtığın iki feedbackide inceledim fakat OpenSSH'ı 7.4p1-5 sürümüne nasıl güncelleyebilirim?

« Yanıtla #5 : »
GitHub bitişik yazılır...
İnsanlar benim dünyayı olduğu gibi kabul edebileceğimi söylüyorlar. Saçmalık! Ben bu dünyayı kabul etmiyorum.” ― rms

« Yanıtla #6 : »
GitHub bitişik yazılır...
Belki sadece orayı söylenildiği gibi yazmıştır! Zaten -birleşik- kelime olur kendileri. Misal "App le" diye bölmemiş. Burada şirketi kastetmemiş sonuçta bahsettiği şey şirketin ismi değil. Esasen sorun yok yani. Önemli olan anlam bozukluğu yaratıp yaratmadığı.

« Yanıtla #7 : »
ayrıca arkadaşlar sudo apt-get update dediğimde şöyle bir hata almaktayım sonda
Kod: [Seç]
Hata:  6 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main i386 Packages
  404  Not Found
Yoksay:8 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main all Packages
Yoksay:9 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main amd64 Packages
Yoksay:10 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main Translation-tr_TR
Yoksay:11 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main Translation-tr
Yoksay:12 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main Translation-en
Yoksay:13 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main amd64 DEP-11 Metadata
Yoksay:14 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main all DEP-11 Metadata
Yoksay:15 http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety/main DEP-11 64x64 Icons
Paket listeleri okunuyor... Bitti
W: 'http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu yakkety Release' deposunda Release dosyası yok.
N: Böyle bir depodan gelen verilerin kaynağı doğrulanamayacağı için bu deponun kullanımı olası tehlike arz etmektedir.
N: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir.
E: http://ppa.launchpad.net/mc3man/gstffmpeg-keep/ubuntu/dists/yakkety/main/binary-i386/Packages alınamadı 404  Not Found
E: Bazı indeks dosyaları indirilemedi. Bu dosyalar yok sayıldılar ya da önceki sürümleri kullanıldı.

« Yanıtla #8 : »
@admiralkheir, openssh-client paketinin 7.4 sürümü Ubuntu'nun 17.04 sürümü için derlenmiş. 16.10 sürümüne aktarılmayabilir, aktarılacaksa da biraz zaman alabilir. O yüzden size önerdiğim yöntemle işinizi yapmaya devam etmeniz gerekiyor. İsterseniz 17.04 sürümündeki paketi kurabilirsiniz fakat bu da başka sorunlara yol açabilir.

Forumumuzda bir başlık altında sadece tek bir soru/sorunu konuşuyoruz. Aldığınız uyarılara dair arama yaptığınızda forumumuzda bu uyarıların nedenleri ve çözümlerine dair konulara ulaşabileceksiniz.