Gönderen Konu: Eclipse sorunu  (Okunma sayısı 1522 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Merhabalar. Bu;

Kod: [Seç]
sudo apt-get install eclipse
komut ile kurduğum Eclipse'yi başlatmak istediğimde aşağıdaki resimdeki gibi bir hata veriyor;



Acaba sorun ne olabilir? Yardımcı olabilirseniz sevinirim. Teşekkürler.
İnsanlar benim dünyayı olduğu gibi kabul edebileceğimi söylüyorlar. Saçmalık! Ben bu dünyayı kabul etmiyorum.” ― rms

« Yanıtla #1 : »
Kod: [Seç]
sudo update-alternatives --config javakomutu ile sisteminizde başka java sürümleri kurulu ise onları seçip deneyebilirsiniz.

« Yanıtla #2 : »
Kod: [Seç]
sudo update-alternatives --config javakomutu ile sisteminizde başka java sürümleri kurulu ise onları seçip deneyebilirsiniz.

Eclipse'nin hata verdiği Java sürümü;

Kod: [Seç]
java version "9-ea"
Java(TM) SE Runtime Environment (build 9-ea+140)
Java HotSpot(TM) 64-Bit Server VM (build 9-ea+140, mixed mode)

Ancak sizin verdiğiniz yöntem ile aşağıdaki Java sürümü ile sorun çözüldü;

Kod: [Seç]
openjdk version "1.8.0_111"
OpenJDK Runtime Environment (build 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14)
OpenJDK 64-Bit Server VM (build 25.111-b14, mixed mode)

Ancak internetten dosya ve torrent indirmek için JDownloader ve FrostWire adında iki program kullanıyorum ve bu sefer onlar OpenJDK ile sorun çıkartıyorlar. Eclipse kullandıktan sonra (aynı anda kullanılamayacağına göre) diğer bir programa geçmek içinde sürekli Java sürümünü değiştirmek gerekiyor. Acaba bunun daha pratik bir çözümü yok mu?
İnsanlar benim dünyayı olduğu gibi kabul edebileceğimi söylüyorlar. Saçmalık! Ben bu dünyayı kabul etmiyorum.” ― rms

« Yanıtla #3 : »
İkisinin de çalıştığı bir sürüm bulana kadar bende ancak bu çözüm var.
Bir kaç gün içinde başka arkadaşlar bir çözüm önerebilirler belki.

« Yanıtla #4 : »
@OnLive
aga eclipse nin neden eski sürümünü kullanıyosun şahsen ben mars sürümünü kullanıyorum gayet de iyi yani bi sıkıntı çıkarmıyo. openjdk nın son versiyonunu kur sonrada eclipse marsı kur(benim kişisel tercihim) oldu bitti.

Tek sıkıntısı vardı onuda bulana kadar canım çıktı.Eclipse nin GTK 3 versiyonunu kullanan sürümleri efsane *kasıyor linux ta.Bunu düzeltmek için:
eclipse dosyasının iiçindeki "eclipse.ini" yi açç.sonra şunu başa ekle:
--launcher.GTK_version
2

sonra kaydedip çık.Artık eclipse nin o kadar kasmaması lazım ben böyle çözdüm sana kolay gele :D
« Son Düzenleme: 18 Aralık 2016 - 05:07:02 Gönderen: Death Pro »

« Yanıtla #5 : »
@OnLive
aga eclipse nin neden eski sürümünü kullanıyosun şahsen ben mars sürümünü kullanıyorum gayet de iyi yani bi sıkıntı çıkarmıyo. openjdk nın son versiyonunu kur sonrada eclipse marsı kur(benim kişisel tercihim) oldu bitti.

Tek sıkıntısı vardı onuda bulana kadar canım çıktı.Eclipse nin GTK 3 versiyonunu kullanan sürümleri efsane *kasıyor linux ta.Bunu düzeltmek için:
eclipse dosyasının iiçindeki "eclipse.ini" yi açç.sonra şunu başa ekle:
--launcher.GTK_version
2

sonra kaydedip çık.Artık eclipse nin o kadar kasmaması lazım ben böyle çözdüm sana kolay gele :D

Ben depolarda bulunan sürümü kurdum. JDownloader ve FrostWire, OpenJDK'da sorun çıkartıyor. Oracle Java istiyorlar sanırım. Bu arada siz önerince Google'a Eclipse Mars yazıp karşıma çıkan ilk sonuca tıkladım. Hemen uyarı yazısı çıktı bu sürüme dair;

Alıntı
Mars is a past version of Eclipse. Please visit our download page for the latest version of Eclipse.

Sanırım önerdiğiniz sürümde eski bir versyona ait;

http://goo.gl/lH6Jkf
İnsanlar benim dünyayı olduğu gibi kabul edebileceğimi söylüyorlar. Saçmalık! Ben bu dünyayı kabul etmiyorum.” ― rms

« Yanıtla #6 : »
@OnLive
aga eclipse nin neden eski sürümünü kullanıyosun şahsen ben mars sürümünü kullanıyorum gayet de iyi yani bi sıkıntı çıkarmıyo. openjdk nın son versiyonunu kur sonrada eclipse marsı kur(benim kişisel tercihim) oldu bitti.

Tek sıkıntısı vardı onuda bulana kadar canım çıktı.Eclipse nin GTK 3 versiyonunu kullanan sürümleri efsane *kasıyor linux ta.Bunu düzeltmek için:
eclipse dosyasının iiçindeki "eclipse.ini" yi açç.sonra şunu başa ekle:
--launcher.GTK_version
2

sonra kaydedip çık.Artık eclipse nin o kadar kasmaması lazım ben böyle çözdüm sana kolay gele :D

Ben depolarda bulunan sürümü kurdum. JDownloader ve FrostWire, OpenJDK'da sorun çıkartıyor. Oracle Java istiyorlar sanırım. Bu arada siz önerince Google'a Eclipse Mars yazıp karşıma çıkan ilk sonuca tıkladım. Hemen uyarı yazısı çıktı bu sürüme dair;

Alıntı
Mars is a past version of Eclipse. Please visit our download page for the latest version of Eclipse.

Sanırım önerdiğiniz sürümde eski bir versyona ait;

http://goo.gl/lH6Jkf
@OnLive
:D::::DD:D evet Neon dan bir önceki sürümdür .Ama neonda ben hatalar almıştım.O hataları marsta almadım.Dediğim gibi benim kendi düşüncem marsı seçmem.Banada bi arkadaşım önermişti marsı kullan diye daha *kararlı diyordu.Bence sende bi dene bi sıkıntı olucağını sanmıyorum ha illa en son sürümünü kullanıcam diyosan sen bilirsin :D

« Yanıtla #7 : »
Oracle javanın kararsız sürümünü kullanmak yerine son çıkan kararlı sürümü bir deneyin. Hiçbir yazılımda sorun çıkarmaması lazım.

« Yanıtla #8 : »
öncelikle openjdk ve mevcut oracle jdk kaldırın sonra

Kod: [Seç]
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer
sudo apt-get install oracle-java8-set-default

openjdk kaldırmak için basit olarak
Kod: [Seç]
sudo apt-get autoremove openjdk* demeniz yeterli olacakdır.

« Yanıtla #9 : »
Merhabalar
Eclipse neon yükledim ubuntu 16.04 'e ve programı çalıştırdığım zaman bu hatayı alıyorum: An error has occurred. See the log file
/home/abt/workspace/.metadata/.log.

yardımcı ederseniz sevinirim.
teşekkürler.

« Yanıtla #10 : »
Kod: [Seç]
/home/abt/workspace/.metadata/.log

burada bir hata kaydı oluşturulmuş hata içeriğine bakabilirsin yada konu açıp paylaşır yardım alırsın

« Yanıtla #11 : »
sudo update-alternatives --config java 
bu kod ile sürüm değişikliği yaptım ve sorunumu gidermiş bulunmaktayım.Teşekkürler.

« Yanıtla #12 : »
Aynı sorun bende de vardı. Teşekkürler