Gönderen Konu: FGLRX kurulmuyor (14.04) Xorg ile çakışıyor!  (Okunma sayısı 1054 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Kod: [Seç]
kharon@FurkanComp:~$ sudo apt-get install mesa-utils
[sudo] password for kharon:
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
mesa-utils zaten en yeni sürümde.
mesa-utils elle kurulmuş olarak ayarlı.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
N: '/etc/apt/sources.list.d/' dizinindeki 'steam.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor.
N: '/etc/apt/sources.list.d/' dizinindeki 'steam.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor.
kharon@FurkanComp:~$ ^C
kharon@FurkanComp:~$
Kod: [Seç]
kharon@FurkanComp:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty
kharon@FurkanComp:~$
Kod: [Seç]
kharon@FurkanComp:~$ lspci -nnk | grep "VGA\|3D\|Display" -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Toshiba America Info Systems Device [1179:f945]
Kernel driver in use: i915
--
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Venus PRO [Radeon HD 8850M / R9 M265X] [1002:6823] (rev ff)
Kernel driver in use: radeon
03:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
kharon@FurkanComp:~$
Kod: [Seç]
kharon@FurkanComp:~$ glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp,
kharon@FurkanComp:~$
Kod: [Seç]
kharon@FurkanComp:~$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1920x1080      60.0*+   59.9 
   1680x1050      60.0     59.9 
   1600x1024      60.2 
   1400x1050      60.0 
   1600x900       60.0 
   1280x1024      60.0 
   1440x900       59.9 
   1280x960       60.0 
   1368x768       60.0 
   1360x768       59.8     60.0 
   1152x864       60.0 
   1280x720       60.0 
   1024x768       60.0 
   1024x576       60.0 
   960x540        60.0 
   800x600        60.3     56.2 
   864x486        60.0 
   640x480        59.9 
   720x405        60.0 
   640x360        60.0 
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
kharon@FurkanComp:~$
Kod: [Seç]
dpkg -l | egrep "nvidia|bumblebee|nvidia-prime|fglrx"

FGLRX kurmaya çalıştığımda da gdebi paket yükleyici xorg core paketi fglrx core paketi ile çakışmaktadır diye uyarı veriyor. Steam'de oyunlar açılıyor fakat çok donuyor bu fglrx'e geçmem lazım yardımcı olursanız sevinirim.

« Yanıtla #1 : »
@kharonubuntu, çıktılara bakalım.
Kod: [Seç]
ubuntu-drivers list
ubuntu-drivers devices

« Yanıtla #2 : »
Kod: [Seç]
kharon@FurkanComp:~$ ubuntu-drivers list
fglrx-updates
fglrx
kharon@FurkanComp:~$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v00001002d00006823sv00001179sd0000F945bc03sc80i00
vendor   : Advanced Micro Devices, Inc. [AMD/ATI]
model    : Venus PRO [Radeon HD 8800M Series]
driver   : xserver-xorg-video-ati - distro free builtin recommended
driver   : fglrx - distro non-free
driver   : fglrx-updates - distro non-free

kharon@FurkanComp:~$
Sistemin çok sağlıklı çalışmadığını hissediyorum grafik kartından bağımsız olarak da.  Ne yapmaya çalışsam kodlar hep hata veriyor paket bozuk geçersiz dosya felan tarzı.

« Yanıtla #3 : »
@kharonubuntu, çıktılara bakalım.
Kod: [Seç]
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx