Gönderen Konu: [Nasıl] Numlock tuşunun otomatik açılması  (Okunma sayısı 1815 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Bir arkadaşı linux kullanmaya ikna ettikten sonra numlock tuşunun otomatik açılmayışını sorun etmişti,
Bütün masaüstlerinde denedigim çözümden başka yararlanmak isteyenler olabilir, işlem çok kolaydır.

Önce uçbirimden numlockx paketini kuruyoruz

Kod: [Seç]
sudo apt-get install numlockx
Sonra default dosyasını açıyoruz ( "gedit" yazısının yerine kendi masaüstümüzün not defterini yazıyoruz)

Kod: [Seç]
sudo gedit  /etc/gdm3/Init/Default
Açılan dosyanın  en sonuna alttaki kodu yapıştırıyor ve kaydediyoruz

Kod: [Seç]
if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi
Bazı masaüstleri nereye kaydedilecegini sorar, böyle durumda önce dosyanın ismini numlockx yapıyor ve etc/init klasörü içine kaydediyoruz.
« Son Düzenleme: 10 Şubat 2016 - 12:09:26 Gönderen: grayloop »
GNU/Linux kullanmıyorum, onu yaşıyorum...

« Yanıtla #1 : »
Merhaba.
 Bende Numlock tuşunun otamatik açılmasını istiyordum ama sizin önerdiğiniz ikinci komutta hata aldım
Kod: [Seç]
asa@mint:~ > sudo kate  /etc/gdm3/Init/Default
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Error: "/var/tmp/kdecache-asa" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-asa" is owned by uid 1000 instead of uid 0.
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon

Boş bir not defteri açılıyor. Hadi üçncü komutu yazayım diyorum yetkili olmadığım için kaydetmeyi kabul etmiyor.  Sonta Kök Dizinden  '' gdm3 ''dosyasını arattım böyle bir  dosya bulmadı.Bendeki sorun  gdm3 dosyanın olmamasıydı diye düşğnüyorum.

Not: Linux Mint 17.3 KDE kullanıyorum








Devler gibi eserler bırakmak için,karıncalar gibi çalışmak lazım.
 -Necip Fazıl Kısakürek

« Yanıtla #2 : »
Alıntı yapılan: glsbrs47
Not: Linux Mint 17.3 KDE kullanıyorum
KDE masa üstü için sistem ayarlarınızdan açılışta numlock aktif yapabilirsiniz ek yazılıma ihtiyacınız yok.

« Yanıtla #3 : »
Hocam sistem kurduktan sonra  sistem ayarları==> mdm giriş pencerisi==>  seçenkler ==> Numlock Etkin kısmı sönüktü. Hiç bir şey yapamıyordum.@illedelinux  ve sizin önerinizle şu şekilde çözüldü.

Önce numlocx uygulamasını yüklüyoruz
Kod: [Seç]
sudo apt-get install numlockxSonra       sistem ayarları==> mdm giriş pencerisi==>  seçenkler ==> Numlock Etkin kısmı görünür hale gelince yanındaki kutucuğu işaretledim ve oldu. Teşekkürler @illedelinux ve teşekkürler @AguilaNegra
Devler gibi eserler bırakmak için,karıncalar gibi çalışmak lazım.
 -Necip Fazıl Kısakürek

« Yanıtla #4 : »
https://forum.ubuntu-tr.net/index.php?topic=19135.0

Fazla mal göz çıkartmaz diyelim, teşekkürler :)
Şu anki dosya yolu /etc/gdm3/Init/Default yolu mu?
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #5 : »
@illedelinux verdiğiniz bilgileri kullanarak Viki'deki Num Lock'un açılışta otomatik açılmasını sağlamak sayfasını Ubuntu 17.10 için güncelledim. Sormak istediğim iki konu var. Defalut dosyasının en altında exit 0 yazan bir satır var. Belgenin altına yapıştıracağımız kodu Vikideki ekran görüntüsünde olduğu gibi en alta mı yapıştıracağız, exit 0 satırının bir üstüne yapıştırmak gerekir mi?

İkinci konu ise Xorg, Wayland ile ilgili. Ben Ubuntu 17.10 kullanıyorum ve sanırım sistemim Wayland'ı desteklemediği için olsa gerek öntanımlı ve tek görüntü sunucusu Xorg. Numlock ile ilgili bir sorun da yok, herhangi bir işlem yapmadığım halde kullanıcı giriş ekranından itibaren Numlock otomatik açılıyor. Demek istediğim Ubuntu 17.10 kullanıcılarının bir kısmı Wayland, bir kısmı Xorg kullanmakta. Bu fark, nedeniyle belgede herhangi bir değişiklik yapmamız gerekir mi? Yani "Xorg kullananlar şu işlemleri, Wayland kullananlar bu işlemi yapmalıdır" gibi bir ayrım gerekir mi?

« Yanıtla #6 : »
Birinci soru, fark etmez ama kaideye uymak için exit 0 yazan yerin üstüne.
İkinci soru, başka işleme gerek yok.
Ek bilgi, Debian, Ubuntu tabanlılar masa üstü ayırt edilmeksizin artık numlockx paketini yükledikten sonra kendisi otomatik açılıyor, bu işlemi yapmaya gerek kalmıyor.
Fedora, Arch kendine göre farklı işleme halen ihtiyaç duyuyor...
GNU/Linux kullanmıyorum, onu yaşıyorum...

« Yanıtla #7 : »
Ek bilgi, Debian, Ubuntu tabanlılar masa üstü ayırt edilmeksizin artık numlockx paketini yükledikten sonra kendisi otomatik açılıyor, bu işlemi yapmaya gerek kalmıyor.
Fedora, Arch kendine göre farklı işleme halen ihtiyaç duyuyor...

Teşekkür ederim. Yani açılış ekranında numlock tuşu açılmayan Ubuntu kullanıcılarının artık numlockx paketinin kurulması tek başına yeterli oluyor mu?

« Yanıtla #8 : »
Debian, Ubuntu tabanlıların hepsinde denedim, otomatik açılıyor, hatta masa üstü olmayan Openbox oturumunda dahi numlockx paketini yüklemek yetiyor.
GNU/Linux kullanmıyorum, onu yaşıyorum...

« Yanıtla #9 : »
Tamam o halde. Viki'de sıkça sorulan sorular sayfasında konuyla ilgili olarak numlockx paketinin yüklenilmesini eğer yeterli olmazsa belgede anlatılanları uygulamaları gerektiğini yazacağım.
Teşekkkür ederim.

« Yanıtla #10 : »
Ubuntu 17 .10 için söylenenleri uyguladığım halde olmadı malesef.

Kod: [Seç]
sudo apt-get install numlockx
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
numlockx zaten en yeni sürümde (1.2-7).
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
N: '/etc/apt/sources.list.d/' dizinindeki 'ne0sight-ubuntu-chrome-gnome-shell-artful.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor

Kod: [Seç]
#!/bin/sh
# Stolen from the debian kdm setup, aren't I sneaky
# Plus a lot of fun stuff added
#  -George

PATH="/usr/bin:$PATH"
OLD_IFS=$IFS

gdmwhich () {
  COMMAND="$1"
  OUTPUT=
  IFS=:
  for dir in $PATH
  do
    if test -x "$dir/$COMMAND" ; then
      if test "x$OUTPUT" = "x" ; then
        OUTPUT="$dir/$COMMAND"
      fi
    fi
  done
  IFS=$OLD_IFS
  echo "$OUTPUT"
}

sysresources=/etc/X11/Xresources

# merge in defaults
if [ -f "$sysresources" ]; then
    xrdb -merge "$sysresources"
fi

sysmodmap=/etc/X11/Xmodmap

XMODMAP=`gdmwhich xmodmap`
if [ "x$XMODMAP" != "x" ] ; then
  if [ "x$GDM_PARENT_DISPLAY" = "x" ]; then
    if [ -f $sysmodmap ]; then
      $XMODMAP $sysmodmap
    fi
  else
    ( DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $XMODMAP -pke ) | $XMODMAP -
  fi

  #
  # Switch Sun's Alt and Meta mod mappings
  #

  UNAME=`gdmwhich uname`
  PROCESSOR=`$UNAME -p`
  if [ "x$PROCESSOR" = "xsparc" ]; then
    if $XMODMAP | grep mod4 | grep Alt > /dev/null 2>/dev/null
    then
      $XMODMAP -e "clear Mod1" \
               -e "clear Mod4" \
               -e "add Mod1 = Alt_L" \
               -e "add Mod1 = Alt_R" \
               -e "add Mod4 = Meta_L" \
               -e "add Mod4 = Meta_R"
    fi
  fi
fi

SETXKBMAP=`gdmwhich setxkbmap`
if [ "x$SETXKBMAP" != "x" ] ; then
  # FIXME: is this all right?  Is this completely on crack?
  # What this does is move the xkb configuration from the GDM_PARENT_DISPLAY
  # FIXME: This should be done in code.  Or there must be an easier way ...
  if [ -n "$GDM_PARENT_DISPLAY" ]; then
    XKBSETUP=`( DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $SETXKBMAP -v )`
    if [ -n "$XKBSETUP" ]; then
      XKBKEYMAP=`echo "$XKBSETUP" | grep '^keymap' | awk '{ print $2 }'`
      XKBTYPES=`echo "$XKBSETUP" | grep '^types' | awk '{ print $2 }'`
      XKBCOMPAT=`echo "$XKBSETUP" | grep '^compat' | awk '{ print $2 }'`
      XKBSYMBOLS=`echo "$XKBSETUP" | grep '^symbols' | awk '{ print $2 }'`
      XKBGEOMETRY=`echo "$XKBSETUP" | grep '^geometry' | awk '{ print $2 }'`
      if [ -n "$XKBKEYMAP" ]; then
        $SETXKBMAP -keymap "$XKBKEYMAP"
      elif [ -n "$XKBTYPES" -a -n "$XKBCOMPAT" -a -n "$XKBSYMBOLS" -a -n "$XKBGEOMETRY" ]; then
        $SETXKBMAP -types "$XKBTYPES" -compat "$XKBCOMPAT" -symbols "$XKBSYMBOLS" -geometry "$XKBGEOMETRY"
      elif [ -n "$XKBTYPES" -a -n "$XKBCOMPAT" -a -n "$XKBSYMBOLS" ]; then
        $SETXKBMAP -types "$XKBTYPES" -compat "$XKBCOMPAT" -symbols "$XKBSYMBOLS"
      elif [ -n "$XKBSYMBOLS" ]; then
        $SETXKBMAP -symbols "$XKBSYMBOLS"
      fi
    fi
  fi
fi
if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi
exit 0
« Son Düzenleme: 30 Ekim 2017 - 20:57:07 Gönderen: Nabi »
Devler gibi eserler bırakmak için,karıncalar gibi çalışmak lazım.
 -Necip Fazıl Kısakürek

« Yanıtla #11 : »
numlockx paketini yükledikten sonra  /etc/default/numlockx ve /etc/X11/Xsession.d/55numlockx yollarında otomatik olarak dosya oluşur, ayrı bir işlem yapmaya gerek yok, eğer bu dosyalar yoksa alttaki gibi manuel olarak oluşturup deneyin.

Önce yüklemediyseniz...
Kod: [Seç]
sudo apt-get install numlockx
Şimdi her iki yolda bahsettiğim dosyaların oluşup oluşmadığını kontrol edin, dosyalar yoksa alttaki yönergeye devam edin.

/etc/default/ yolunda boş bir not defteri içine alttakini yapıştırın, ismini numlockx yapın, kaydedin ve kapatın.
Kod: [Seç]
# Configuration file for numlockx

# State of numlog on start of X session
# Accepts following options:
#  auto - turns numlock on unless ran on laptop
#  on - turns numlock on
#  off - turns numlock off
#  keep - does not change numlock state
#  toggle - toggles numlock state
NUMLOCK=auto

/etc/X11/Xsession.d/ yolunda boş bir not defteri içine alttakini yapıştırın, ismini 55numlockx yapın, kaydedin ve kapatın.
Kod: [Seç]
# Initial settings
NUMLOCK=auto

# Load configuration
cf=/etc/default/numlockx
[ ! -r $cf ] || . $cf

# Toggle numlock if we're not removed
nlx=/usr/bin/numlockx
[ ! -x $nlx ] || {
    case $NUMLOCK in
        # 'keep' is an undocumented state (see `man 1 numlockx'), though
        # /etc/default/numlockx mentions it; do nothing
        keep)
            return 0
            ;;
        off|on|toggle)
            ;;
        *)
            NUMLOCK=on
            ltd=/usr/sbin/laptop-detect
            [ ! -x $ltd ] || ! $ltd || NUMLOCK=off
            # Enable numlock for USB keyboard on laptop
            if [ -f /bin/udevadm ] ; then
                for kbd in `udevadm trigger --dry-run --verbose --property-match=ID_INPUT_KEYBOARD=1` ; do
                    if udevadm info --query=env --path=$kbd | grep -q '^DEVNAME=' ; then
                        continue
                    fi
                    if udevadm info --query=env --path=$kbd | grep -q '^ID_USB_DRIVER=usbhid' ; then
                        NUMLOCK=on
                    fi
                done
            fi
            ;;
    esac
    $nlx $NUMLOCK || :
}

# EOF

Bu işlemi yaptıktan sonra eğer numlock tuşu otomatik açılmıyorsa sürüm desteği yok demektir, ancak buna ihtimal vermiyorum, zira son sürümlerin bazı masa üstlerinde numlockx paketi varsayılan olarak yüklü geliyor.
GNU/Linux kullanmıyorum, onu yaşıyorum...

« Yanıtla #12 : »
GDM giriş pencresinde Numlock tuşunun otomatik açılması burdaki bağlantıya göre bende çalıştı.Terminalı açıp sırasyla aşağıdaki komutları sırasıyla girdikten sonra bilgisayarı tekrar başlatırsanız aktif  oluyor

Kod: [Seç]
sudo apt-get install numlockx
Kod: [Seç]
sudo -i
Kod: [Seç]
xhost +SI:localuser:gdm
Kod: [Seç]
su gdm -s /bin/bash
Kod: [Seç]
gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'
Kod: [Seç]
gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true
Devler gibi eserler bırakmak için,karıncalar gibi çalışmak lazım.
 -Necip Fazıl Kısakürek