Gönderen Konu: localhost apache sorunu  (Okunma sayısı 1134 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Selamlar wiki.ubuntu-tr.net deki anlatıma göre apache, php, mysql kurulumu yaptım localhost da drupal denemeleri yapmak için * her şey düzgün çalışıyor fakat http://localhost/drupal/admin/modules linkleri çalışmıyor acaba apache .htaccess dosyalarınımı okumuyor bu sonrunu nasıl çözebilirim?

« Yanıtla #1 : »
Drupal'ın kendisi çalışıyor ancak verdiğin bağlantı mı çalışmıyor? Normal şartlar altında .htaccess dosyasına bir şey işlenmesi gerekiyor mu? Çalışmıyor ama ne oluyor? Hata mı veriyor, boş sayfa mı döndürüyor, ne oluyor yani?
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #2 : »
php ve apache düzgün çalışıyor drupal ı sorunsuz yükledi .htaccess i de oluşturdu ve içine gerekli kodrarı yazdı index.php?action=post;topic=49905.0;last_msg=570474 şeklindeki linkleri drupal http://localhost/drupal/user olarak seo için otomatik değiştiriyor ve bu linkler localhostum da çalışmıyor herhangi bir linke tıklarsam:

Not Found

The requested URL /drupal/node/add was not found on this server.

Apache/2.4.12 (Ubuntu) Server at localhost Port 80

hatası alıyorum

« Yanıtla #3 : »
Bu durumda ya .htaccess girdisinde sorun vardır ya da Drupal tarafındaki SEO ayarlarında. Açıkçası Drupal için ne gerektiğini bilmediğim için net bir şey söylemem mümkün değil. Biraz araştırıp çözüm arayabilirsin Google tarafında. .htaccess dosyasının içeriğini de buraya geçersen en azından Drupal ile içli dışlı olanlar bakınmaya çalışabilir.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #4 : »
Merhabalar, linux a ara vermiştim bugün windows pc de mavi ekran hatası alınca tekrar linux debian dağıtımına geçtim. Sitemi kurdum ve sisteme lamp kurulumu yaptım ama sef url ler gene çalışmadı google de çözümü ararken uzun zaman önce kendi açtığım konuma rastladım ve çözülmemişti çözümü bu sefer yabancı forumlar yardımıyla buldum Türkçe kaynak olması açısından burada paylaşmaya karar verdim.

öncelikle terminalde
su
komutuyla root oluyoruz

sonra
/var/www/html dizini içerisine info.php diye bir dosya oluşturalım ve içerisine
Kod: [Seç]
<?php phpinfo(); ?>komutlarını ekleyelim. Ardından internet tarayıcımıza http://localhost/info.php adresini yazalım. Açılan sayfadaki tabloda Loaded Modules in karşısında sistemde etkin modüller gözükecektir. Modüllerin arasında mod_rewrite modülünün olup olmadığını kontrol edelim. Eğer yoksa

Terminalde:
a2enmod rewrite
konutunu girelim ve service apache2 restart komutu ile apache web sunucumuzu etkinleştirdiğimiz modülün çalışması için yeniden başlatalım.
http://localhost/info.php sayfasını tekrar açalım ve mod_rewrite modülünün gelip gelmediğini kontrol edelim. Eğer geldiyse:
gedit /etc/apache2/sites-available/000-default.conf komutunu terminalde girelim ve metin düzenleyici açılınca en üstte bulunan
Kod: [Seç]
<VirtualHost *:80>kısmını
Kod: [Seç]
<VirtualHost *:80>
    <Directory /var/www/html>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require all granted
    </Directory>
olarak değiştirelim. service apache2 restart komutu ile web sunucumuzu yeniden başlatalım artık sef url lerin sorunsuz çalışması gerekli.