Gönderen Konu: [Çözüldü] İnternet olmayan bir sisteme C++ derleyicisi nasıl kurulur?  (Okunma sayısı 1831 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Arkadaşlar c++ için kod yazacam ama c++ derleyicisin 32 bit ubuntu için bulamadım ubuntu pacageste arama yaptım gcc çıkıyor...
« Son Düzenleme: 25 Ekim 2014 - 10:23:00 Gönderen: Nurullah_RT »
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #1 : »
Kod: [Seç]
sudo apt-get install g++

« Yanıtla #2 : »
yada

Kod: [Seç]
sudo apt-get install binutils

« Yanıtla #3 : »
YARDIMLARINIZ İÇİN TEŞEKKÜRLER AMA BİLGİSAYARDA İNTERNET YOK... :'( :'( :'(
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #4 : »
@Nurullah_RT, tüm iletilerini büyük harfle yazma lütfen. 
Ayrıca, internet yoksa makinede diğer konularda verilen cevaplar geçerli senin için. Dikkatle incelersen aynısını bu başlık için de uygulayabilirsin.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #5 : »
g++ zaten varsayılan olarak kurulu gelmiyormu ? Uçbirimde
Kod: [Seç]
g++yaz
Kod: [Seç]
g++: ölümcül hata: girdi dosyası yok
derleme sonlandırıldı.
Bunu gibi bir hata bildirimi alırsan, g++ kurulu ve kullanıma hazır. Devamını buradan https://forum.ubuntu-tr.net/index.php?board=111.0   
araştırabilirsin.

« Yanıtla #6 : »
C++ derleyicisi kurulu gelmiyor sanırım @ekremsenturk.
http://releases.ubuntu.com/releases/trusty/ubuntu-14.04-desktop-amd64.manifest

« Yanıtla #7 : »
g++ zaten varsayılan olarak kurulu gelmiyormu ? Uçbirimde
Kod: [Seç]
g++yaz
Kod: [Seç]
g++: ölümcül hata: girdi dosyası yok
derleme sonlandırıldı.
Bunu gibi bir hata bildirimi alırsan, g++ kurulu ve kullanıma hazır. Devamını buradan https://forum.ubuntu-tr.net/index.php?board=111.0   
araştırabilirsin.

hayır ubuntu 14.04 te yüklü olarak gelmedi.
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #8 : »
İnternet cafe veya bir başkasının bilgisayarından "g++.deb" arama terimi ile ara. Çıkan sonuçlar arasından Ubuntu ve doğru sürümün deposu olduğuna emin olduğun arama sonucunu aç ve oradan indir. Gerekli bağımlılıklar da belirtilmiştir, onları da indir ve bir veri taşıyıcıya kayıt et. sonra ev de yüklersin.

Veya geçici olarak bir yerden internete bağlan ve Ubuntu ile indir, daha sağlıklı olur. Bağlanmak için hiç bir imkân bulamasan bile, cep telefonunu modem olarak kullanabilirsin. Blutooth veya usb bağlantısı kullanabilirsin. Forumda biraz eski konular arasında nasıl yapılacağı yazılmıştı diye hatırlıyorum.

Buradan da OpenWatcom C/C++ derleyicisini indirebilirsin :   http://openwatcom.mirrors.pair.com/
« Son Düzenleme: 16 Ekim 2014 - 20:07:32 Gönderen: ekremsenturk »

« Yanıtla #9 : »
Kod: [Seç]
apt-rdepends -p g++
Kod: [Seç]
g++
  Depends: cpp (>= 4:4.8.2-1ubuntu6) [Installed]
  Depends: g++-4.8 (>= 4.8.2-5~) [Installed]
  Depends: gcc (>= 4:4.8.2-1ubuntu6) [Installed]
  Depends: gcc-4.8 (>= 4.8.2-5~) [Installed]
cpp
  Depends: cpp-4.8 (>= 4.8.2-5~) [Installed]
cpp-4.8
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libcloog-isl4 (>= 0.17) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.10) [Installed]
  Depends: libmpc3 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  Depends: zlib1g (>= 1:1.1.4) [Installed]
gcc-4.8-base
libc6
  Depends: libgcc1 [Installed]
libgcc1
  Depends: gcc-4.9-base (= 4.9-20140406-0ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
gcc-4.9-base
multiarch-support
  Depends: libc6 (>= 2.3.6-2) [Installed]
libcloog-isl4
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.11) [Installed]
  PreDepends: multiarch-support [Installed]
libgmp10
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libisl10
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libgmp10 [Installed]
  PreDepends: multiarch-support [Installed]
libmpc3
  Depends: libc6 (>= 2.3.4) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  PreDepends: multiarch-support [Installed]
libmpfr4
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libgmp10 [Installed]
  PreDepends: multiarch-support [Installed]
zlib1g
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
g++-4.8
  Depends: gcc-4.8 (= 4.8.2-19ubuntu1) [Installed]
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libcloog-isl4 (>= 0.17) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.10) [Installed]
  Depends: libmpc3 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  Depends: libstdc++-4.8-dev (= 4.8.2-19ubuntu1) [Installed]
  Depends: zlib1g (>= 1:1.1.4) [Installed]
gcc-4.8
  Depends: binutils (>= 2.24) [Installed]
  Depends: cpp-4.8 (= 4.8.2-19ubuntu1) [Installed]
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libcloog-isl4 (>= 0.17) [Installed]
  Depends: libgcc-4.8-dev (= 4.8.2-19ubuntu1) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.10) [Installed]
  Depends: libmpc3 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  Depends: zlib1g (>= 1:1.1.4) [Installed]
binutils
  Depends: libc6 (>= 2.14) [Installed]
  Depends: zlib1g (>= 1:1.2.0) [Installed]
libgcc-4.8-dev
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libasan0 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libatomic1 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libgcc1 (>= 1:4.8.2-19ubuntu1) [Installed]
  Depends: libgomp1 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libitm1 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libquadmath0 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libtsan0 (>= 4.8.2-19ubuntu1) [Installed]
libasan0
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.4) [Installed]
  Depends: libgcc1 (>= 1:4.1.1) [Installed]
  PreDepends: multiarch-support [Installed]
libatomic1
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libgomp1
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.17) [Installed]
  PreDepends: multiarch-support [Installed]
libitm1
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libquadmath0
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libtsan0
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.4) [Installed]
Depends: libgcc1 (>= 1:4.1.1) [Installed]
  PreDepends: multiarch-support [Installed]
libstdc++-4.8-dev
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6-dev (>= 2.13-0ubuntu6) [Installed]
  Depends: libgcc-4.8-dev (= 4.8.2-19ubuntu1) [Installed]
  Depends: libstdc++6 (>= 4.8.2-19ubuntu1) [Installed]
libc6-dev
  Depends: libc-dev-bin (= 2.19-0ubuntu6) [Installed]
  Depends: libc6 (= 2.19-0ubuntu6) [Installed]
  Depends: linux-libc-dev [Installed]
libc-dev-bin
  Depends: libc6 (<< 2.20) [Installed]
linux-libc-dev
libstdc++6
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.17) [Installed]
  Depends: libgcc1 (>= 1:4.1.1) [Installed]
  PreDepends: multiarch-support [Installed]
gcc
  Depends: cpp (>= 4:4.8.2-1ubuntu6) [Installed]
  Depends: gcc-4.8 (>= 4.8.2-5~) [Installed]

Görülebileceği üzere internet edinmek daha makul. Eğer internet kafeden yapılacaksa illa ki açarsın Ubuntu'yu, sonra da uçbirimi:

Kod: [Seç]
sudo apt-get clean
sudo apt-get --download-only install g++

dersin. Böylece paketler kurulmadan /var/cache/apt/archives dizini içine indirilirler. Bu paketleri bir USB ile evdeki Ubuntu'ya taşırsın, masaüstünde bir dizine atar sonra o dizinde şu komutu vererek kurarsın:

Kod: [Seç]
sudo dpkg -i *.deb
Ubuntu sürümü aynı olmalı.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #10 : »
Bana kalırsa, arkadaş IDE istemiş gibi. C++ için en iyi IDE, QtCreator. 
Tabi yine internet lazım.
Good morning and welcome to the Black Mesa Transit System. This automated train is provided for the security and convenience of the Black Mesa Research Facility personnel.

« Yanıtla #11 : »
Kod: [Seç]
apt-rdepends -p g++
Kod: [Seç]
g++
  Depends: cpp (>= 4:4.8.2-1ubuntu6) [Installed]
  Depends: g++-4.8 (>= 4.8.2-5~) [Installed]
  Depends: gcc (>= 4:4.8.2-1ubuntu6) [Installed]
  Depends: gcc-4.8 (>= 4.8.2-5~) [Installed]
cpp
  Depends: cpp-4.8 (>= 4.8.2-5~) [Installed]
cpp-4.8
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libcloog-isl4 (>= 0.17) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.10) [Installed]
  Depends: libmpc3 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  Depends: zlib1g (>= 1:1.1.4) [Installed]
gcc-4.8-base
libc6
  Depends: libgcc1 [Installed]
libgcc1
  Depends: gcc-4.9-base (= 4.9-20140406-0ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
gcc-4.9-base
multiarch-support
  Depends: libc6 (>= 2.3.6-2) [Installed]
libcloog-isl4
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.11) [Installed]
  PreDepends: multiarch-support [Installed]
libgmp10
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libisl10
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libgmp10 [Installed]
  PreDepends: multiarch-support [Installed]
libmpc3
  Depends: libc6 (>= 2.3.4) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  PreDepends: multiarch-support [Installed]
libmpfr4
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libgmp10 [Installed]
  PreDepends: multiarch-support [Installed]
zlib1g
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
g++-4.8
  Depends: gcc-4.8 (= 4.8.2-19ubuntu1) [Installed]
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libcloog-isl4 (>= 0.17) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.10) [Installed]
  Depends: libmpc3 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  Depends: libstdc++-4.8-dev (= 4.8.2-19ubuntu1) [Installed]
  Depends: zlib1g (>= 1:1.1.4) [Installed]
gcc-4.8
  Depends: binutils (>= 2.24) [Installed]
  Depends: cpp-4.8 (= 4.8.2-19ubuntu1) [Installed]
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  Depends: libcloog-isl4 (>= 0.17) [Installed]
  Depends: libgcc-4.8-dev (= 4.8.2-19ubuntu1) [Installed]
  Depends: libgmp10 [Installed]
  Depends: libisl10 (>= 0.10) [Installed]
  Depends: libmpc3 [Installed]
  Depends: libmpfr4 (>= 3.1.2) [Installed]
  Depends: zlib1g (>= 1:1.1.4) [Installed]
binutils
  Depends: libc6 (>= 2.14) [Installed]
  Depends: zlib1g (>= 1:1.2.0) [Installed]
libgcc-4.8-dev
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libasan0 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libatomic1 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libgcc1 (>= 1:4.8.2-19ubuntu1) [Installed]
  Depends: libgomp1 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libitm1 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libquadmath0 (>= 4.8.2-19ubuntu1) [Installed]
  Depends: libtsan0 (>= 4.8.2-19ubuntu1) [Installed]
libasan0
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.4) [Installed]
  Depends: libgcc1 (>= 1:4.1.1) [Installed]
  PreDepends: multiarch-support [Installed]
libatomic1
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libgomp1
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.17) [Installed]
  PreDepends: multiarch-support [Installed]
libitm1
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libquadmath0
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.14) [Installed]
  PreDepends: multiarch-support [Installed]
libtsan0
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.4) [Installed]
Depends: libgcc1 (>= 1:4.1.1) [Installed]
  PreDepends: multiarch-support [Installed]
libstdc++-4.8-dev
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6-dev (>= 2.13-0ubuntu6) [Installed]
  Depends: libgcc-4.8-dev (= 4.8.2-19ubuntu1) [Installed]
  Depends: libstdc++6 (>= 4.8.2-19ubuntu1) [Installed]
libc6-dev
  Depends: libc-dev-bin (= 2.19-0ubuntu6) [Installed]
  Depends: libc6 (= 2.19-0ubuntu6) [Installed]
  Depends: linux-libc-dev [Installed]
libc-dev-bin
  Depends: libc6 (<< 2.20) [Installed]
linux-libc-dev
libstdc++6
  Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) [Installed]
  Depends: libc6 (>= 2.17) [Installed]
  Depends: libgcc1 (>= 1:4.1.1) [Installed]
  PreDepends: multiarch-support [Installed]
gcc
  Depends: cpp (>= 4:4.8.2-1ubuntu6) [Installed]
  Depends: gcc-4.8 (>= 4.8.2-5~) [Installed]

Görülebileceği üzere internet edinmek daha makul. Eğer internet kafeden yapılacaksa illa ki açarsın Ubuntu'yu, sonra da uçbirimi:

Kod: [Seç]
sudo apt-get clean
sudo apt-get --download-only install g++

dersin. Böylece paketler kurulmadan /var/cache/apt/archives dizini içine indirilirler. Bu paketleri bir USB ile evdeki Ubuntu'ya taşırsın, masaüstünde bir dizine atar sonra o dizinde şu komutu vererek kurarsın:

Kod: [Seç]
sudo dpkg -i *.deb
Ubuntu sürümü aynı olmalı.

Keşke internet kafe ubuntu kullansaydı...


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : [time]18 Ekim 2014 - 15:19:33[/time]
Bana kalırsa, arkadaş IDE istemiş gibi. C++ için en iyi IDE, QtCreator.
Tabi yine internet lazım.

Yok ideyi geçtim derleyiciyi bulayım yeter...


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 18 Ekim 2014 - 18:20:50
İnternet cafe veya bir başkasının bilgisayarından "g++.deb" arama terimi ile ara. Çıkan sonuçlar arasından Ubuntu ve doğru sürümün deposu olduğuna emin olduğun arama sonucunu aç ve oradan indir. Gerekli bağımlılıklar da belirtilmiştir, onları da indir ve bir veri taşıyıcıya kayıt et. sonra ev de yüklersin.

Veya geçici olarak bir yerden internete bağlan ve Ubuntu ile indir, daha sağlıklı olur. Bağlanmak için hiç bir imkân bulamasan bile, cep telefonunu modem olarak kullanabilirsin. Blutooth veya usb bağlantısı kullanabilirsin. Forumda biraz eski konular arasında nasıl yapılacağı yazılmıştı diye hatırlıyorum.

Buradan da OpenWatcom C/C++ derleyicisini indirebilirsin :   http://openwatcom.mirrors.pair.com/

g++4.4.6 indirdim gcc4.4.6 isredi onu yüklerken ubuntu yazilim merkezi "broken cache" hatasi verdi artik yükleme yapilmiyor yekrar yukleyeceğim ubuntuyu...
« Son Düzenleme: 18 Ekim 2014 - 18:20:51 Gönderen: Nurullah_RT »
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #12 : »
Ubuntu 14.04 de kurulu olan Gcc sürümü 4.8.

« Yanıtla #13 : »
Ubuntu 14.04 de kurulu olan Gcc sürümü 4.8.
O zaman g++ 4.8 sürümünü indiriyorum.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 19 Ekim 2014 - 14:51:31
Bıktım artık şeytan diyor ki tüm paketleri indir gitsin...
« Son Düzenleme: 19 Ekim 2014 - 14:51:31 Gönderen: Nurullah_RT »
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #14 : »
Ek olarak cpp paketide kurulu olması gerekiyor. (Tabii aynı sürüm) Belki kuruluda olabilir.

« Yanıtla #15 : »
Ek olarak cpp paketide kurulu olması gerekiyor. (Tabii aynı sürüm) Belki kuruluda olabilir.
Evet cpp paketi kurulu ama gcc 4.8 base paketi olmasına rağmen "a later versiyon" gibi bir hata alıyorum acaba nasıl çözeceğim... Çünkü o paket yüklenirse iş bitiyor..
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #16 : »
Hata bildirimini tam ekleyebilseydin iyi olurdu.

Gcc sürümünü tam öğren ve ona uygun g++ sürümünü bulmaya bak. Çünkü 14.04 çıktığından beri bir çok güncelleme geldi. Senin İnternetsiz 14.04'ün bu güncellemelerden uzak kaldı.

« Yanıtla #17 : »
Benim bilgisayarda yüklü olan sürüm gcc 4.8 baktım birde ekstradan gcc 4.7 yükledim. İnternet cafeden farkında g++ 4.8.1 indirdim gcc 4.8.1 base paketini istedi... O paketi yükledim şimdi 'a later version already' hatası alıp yükleyemiyorum. Yani işin içinden bir türlü çıkamadım...


Konu 1 haftadan fazla sürdü farkındayım ama g++ olmasa ubuntu pek işime yarayamayacak gibi duruyor.
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #18 : »
Gcc'yi yükseltme. g++ varsayılan gcc ile aynı sürüm olsun. Gcc derleyicisini yükseltirsen, sistemin geri kalanı ilk kurulum aşamasında olduğu için başka paketler ile sorun yaşarsın. Neden Cepten İnternete bağlanmadın ? Orada sorun çıktımı ? Çevirmeli ağ için farklı markaların farklı GPRS/EDGE/UMTS numarası var. Nokia/Motorola için #99* ve Samsung/Sony için #99***1 (veya 1 yerine SID numarası) Ubntu sürümlerinde de bazen biri, bazen diğeri varsayılan olarak hazır ayarlarda kullanılıyor.

« Yanıtla #19 : »
Şimdi benim telefonda 2 gb internet var ama bir türlü bilgisayara bağlayamadım hadi windowsta olmuyordu telefon tanınmıyordu, ubuntuda mı öyle... Gelelim gcc g++ meselesine yarın deneyeceğim g++ 4.8 indireceğim çünkü gcc 4.8 yüklü... İnşallah olur eğer olmazsa telefonun internetini bağlamaya çalışıp uçbirimden indirmeyi deneyeceğim.


Mesaj tekrarı yüzünden mesajınız birleştirildi. Bu mesajın gönderim tarihi : 21 Ekim 2014 - 15:35:39
Arkaaşlar g++ yı kendisi yükleyecek herhangi bir IDE yokmu çünkü olmuyor g++ 4.8.1 var...
« Son Düzenleme: 21 Ekim 2014 - 15:35:39 Gönderen: Nurullah_RT »
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #20 : »
C/C++ için Derleyici olarak tek paket halinde Tendra var.  Ek olarak (bağımlılık) Tendra-doc indirilmesi gerekiyormuş. Hiç denemedim. Tanıtımında C++ desteğinin çok kısıtlı olduğu yazıyor. Standart kütüphaneleri desteklerse yeterli olması gerekir diye düşünüyorum.

« Yanıtla #21 : »
Keşke internet kafe ubuntu kullansaydı...

Bir adet USB belleğe Ubuntu kurulur, her yere götürülür. İster internet kafe, ister komşu.

Bu şekilde çok uğraşırsın. Sana verdiğim upuzun listeyi gördün mü? O listenin tamamı senin istediğin paketin bağımlılıklarıdır. Bazıları sistemde kurulu olabilir ama kurulu olmayanların hepsini sağlaman gerekir. Kısacası tek tek çok uğraşırsın.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #22 : »
Keşke internet kafe ubuntu kullansaydı...

Bir adet USB belleğe Ubuntu kurulur, her yere götürülür. İster internet kafe, ister komşu.

Bu şekilde çok uğraşırsın. Sana verdiğim upuzun listeyi gördün mü? O listenin tamamı senin istediğin paketin bağımlılıklarıdır. Bazıları sistemde kurulu olabilir ama kurulu olmayanların hepsini sağlaman gerekir. Kısacası tek tek çok uğraşırsın.

@heartsmagic listeni gördüm şimdi ben internet cafede sanal diske ubuntu kursam ve o listeden sonra bir komut vermişdin ya o komutla

sudo apt-get clean
sudo apt-get --download-only install g++

dersin. Böylece paketler kurulmadan /var/cache/apt/archives dizini içine indirilirler. Bu paketleri bir USB ile evdeki Ubuntu'ya taşırsın, masaüstünde bir dizine atar sonra o dizinde şu komutu vererek kurarsın:

sudo dpkg -i *.deb

Ubuntu sürümü aynı olmalı.

yükleme yapıp yapsam olur mu?
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..

« Yanıtla #23 : »
Olur. Evdeki Ubuntu kaç bitse, sanaldaki de o şekilde olsun ama. Zira paketlerin buna uygun olarak inmesi gerekiyor.
Gerçi şimdi sen ne kurdun ne ettin bilmiyorum. Bir de üzerine hata alıyorum demişsin. En kötü dener, tüm çıktıyı buraya aktarırsın.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #24 : »
Olur. Evdeki Ubuntu kaç bitse, sanaldaki de o şekilde olsun ama. Zira paketlerin buna uygun olarak inmesi gerekiyor.
Gerçi şimdi sen ne kurdun ne ettin bilmiyorum. Bir de üzerine hata alıyorum demişsin. En kötü dener, tüm çıktıyı buraya aktarırsın.
Peki yaparım şimdi ben ubuntuyu flash diske kursam flash disk ext4 olacak acaba windows sonradan tekrar ext4 olan bir flash diski okur mu...
Aşkın; gözü kör, kulağı sağır, dili tutuk, aklı kıttır..! Hayır yani bu halde nasıl herkesi madara ediyor onu çözemedim..