Gönderen Konu: [Nasıl] Sources.list - Depo/Kaynak listesi  (Okunma sayısı 93172 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« Yanıtla #1 : »
sources.list (K)ubuntu  program paketlerinin bulunduğu depoların adreslerini içerir. Varsayılan olarak bazı depolar bu listede kapatılmıştır. Bu depoları listeyi değiştirerek kullanabilirsiniz. Ayrıca bu listeye yeni depo adresleri ekleyebilirsiniz. Bu listede yer alan depolardan kurulan programlar root yetkisi ile kurulduğundan güvenilir kaynakları tercih etmeniz tavsiye edilir.


Uygulamalar-Donatılar-Uçbirim ile açacağınız terminalde:

Kod: [Seç]
sudo -H gedit /etc/apt/sources.list
ile dosyayı açıp aşağıdaki dosyayı aynen kendi dosyanızla değiştirin.

Örnek sources.list dosyası. 16.04 Xenail Xerus sürümü içindir, Hollanda yansıları kullanılmıştır. Neden Hollanda yansıları? Çünkü hızlı.
Kaynak depolar kapatılmıştır. Eğer uygulama derlemek için kaynak paketler ihtiyacınız yoksa açılmasına gerek yoktur.
Backports, Partner gibi depolar açık durumdadır.


Kod: [Seç]
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial universe
deb http://nl.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://nl.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://nl.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
# #deb-src http://archive.canonical.com/ubuntu xenial partner


Örnek sources.list dosyası. 14.04 Trusty Tahr sürümü içindir, Hollanda yansıları kullanılmıştır. Neden Hollanda yansıları? Çünkü hızlı.
Kaynak depolar kapatılmıştır. Eğer uygulama derlemek için kaynak paketler ihtiyacınız yoksa açılmasına gerek yoktur.
Backports, Partner gibi depolar açık durumdadır.

Kod: [Seç]
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ trusty main restricted
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ trusty universe
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty universe
deb http://nl.archive.ubuntu.com/ubuntu/ trusty-updates universe
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://nl.archive.ubuntu.com/ubuntu/ trusty multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://nl.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
# deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
# deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
# deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
# #deb-src http://archive.canonical.com/ubuntu trusty partner



Dosyayı kayıt edip çıkın.

Veri tabanını güncelleyin.
Kod: [Seç]
sudo apt-get update
Eğer Ubuntu sürümünüz 15.10 ise aşağıdaki dosyayı kullanın:

Kod: [Seç]
#deb cdrom:[Ubuntu 15.10 _Wily Werewolf_ - Release amd64 (20151021)]/ wily main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ wily main restricted
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ wily-updates main restricted
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ wily universe
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily universe
deb http://nl.archive.ubuntu.com/ubuntu/ wily-updates universe
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://nl.archive.ubuntu.com/ubuntu/ wily multiverse
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily multiverse
deb http://nl.archive.ubuntu.com/ubuntu/ wily-updates multiverse
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ wily-backports main restricted universe multiverse
#deb-src http://nl.archive.ubuntu.com/ubuntu/ wily-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu wily-security main restricted
#deb-src http://security.ubuntu.com/ubuntu wily-security main restricted
deb http://security.ubuntu.com/ubuntu wily-security universe
#deb-src http://security.ubuntu.com/ubuntu wily-security universe
deb http://security.ubuntu.com/ubuntu wily-security multiverse
#deb-src http://security.ubuntu.com/ubuntu wily-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu wily partner
# #deb-src http://archive.canonical.com/ubuntu wily partner

Güncel dil deposunu eklemek için şu başlığı uygulayın:
http://forum.ubuntu-tr.net/index.php/topic,6706.0.html
« Son Düzenleme: 19 Haziran 2016 - 03:58:06 Gönderen: heartsmagic »
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #25 : »
Heartsmagic'in verdiği listeyi aynen değiştirebileceğim söylenmiş, birde bir sonraki mesajda Demir Türkçe'sini vermiş. Önce Heartsmagic'in verdiği listeyi yapıştırıp ardına demir'in verdiği listeyi mi ekleyeceğim?

Not: Sistem->Yönetim->Yazılım Kaynakları işe yarayabilir gibi duruyor.
« Son Düzenleme: 01 Ağustos 2008 - 17:37:46 Gönderen: cashkorkmaz@gmail.com »

« Yanıtla #26 : »
İkisinden birini ekleyin, hız olarak Almanya yansıları daha iyi, bu sebeple onu kullanmanızı öneririm. İçerik olarak hepsi aynı zaten.

Alıntı
Not: Sistem->Yönetim->Yazılım Kaynakları işe yarayabilir gibi duruyor.
Sources.list içeriğini grafik arayüzü ile ayarlamaya yarayan bir program, kullanılabilir, iyi de iş görür.

« Yanıtla #27 : »
Bilgilendirme için teşekkür ederim.

« Yanıtla #28 : »
Uçbirimde sudo apt-get update komutundan sonra şöyle bir hata alıyorum :

Alıntı
Reading package lists... Done
W: GPG error: http://repository.debuntu.org hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E466170BCF1FC29
W: You may want to run apt-get update to correct these problems

Not: Xubuntu kullanıyorum..

« Yanıtla #29 : »
"You may want to run apt-get update to correct these problems"

Sana şöyle bir yol göstermiş denedin mi ?

« Yanıtla #30 : »
"You may want to run apt-get update to correct these problems"

Sana şöyle bir yol göstermiş denedin mi ?

Denediğimde de aynısı oluyor...

« Yanıtla #31 : »
Bence çok önemli bir problem değil. Depolar arasına: http://repository.debuntu.org/ adresini eklemişsiniz. Ancak apt-get, bu yükleme sitesine bağlanmaya çalışırken güvenlik anahtarını (gpg-public key) teyit etmeye çalışıyor ve sitedeki bir sorundan ötürü bunu başaramıyor.

Canınızı çok sıkıyorsa, Synaptic menüsünde bulunan "yazılım kaynakları"nı kullanarak bu 3.parti depoyu geçici olarak devre dışı bırakabilirsiniz.

Ya da: http://repository.debuntu.org/ sayfasının en sonunda bulunan "wget"li satırı konsolda kopyala-yapıştır ile uygulamayı deneyebilirsiniz.

« Yanıtla #32 : »
Kod: [Seç]
wget http://repository.debuntu.org/GPG-Key-chantra.txt -O- | sudo apt-key add -
Deneyebilirmisiniz.

Olmazsa yansı değiştirmeyi deneyin. Örneğin: Almanya, Usa...
« Son Düzenleme: 02 Ağustos 2008 - 20:05:25 Gönderen: izzetguntalaz »

« Yanıtla #33 : »
Teşekkürler sorun çözüldü.
Aynı sorunu yaşayanlar olursa, yukarıda izzetguntalaz ve erginemr (ikisinin de çözüm önerisi aynı) arkadaşların dediği şekilde yaparak çözdüm.

« Yanıtla #34 : »
Opera'nın kaynak listesine eklenmesi:

Kod: [Seç]
sudo gedit /etc/apt/sources.list
Liste altına ekleyin:

Kod: [Seç]
# Opera
deb http://deb.opera.com/opera/ stable non-free

Kaydet ve çık. Uçbirimden devam:

Kod: [Seç]
sudo wget -O - http://deb.opera.com/archive.key | sudo apt-key add -
Kod: [Seç]
sudo apt-get update
Kod: [Seç]
sudo apt-get install opera

« Yanıtla #35 : »
Çok teşekkürler @hasanyılmaz,

Bu benim gibi Opera kullanan ve güncel tutmak isteyen Ubuntu kullanıcıları için güzel bir ipucu oldu.
« Son Düzenleme: 13 Eylül 2008 - 01:09:00 Gönderen: ihtiyar Said »

« Yanıtla #36 : »
Çok teşekkürler @hasanyılmaz,
Bu benim gibi Opera kullanan ve güncel tutmak isteyen Ubuntu kullanıcıları için güzel bir ipucu oldu.

Opera çok iyi bir tarayıcı ama ikinci yerde benim için. Opera'nın güncellemesi kolaydı, haber veriyordu indir, kur diye. Yalnız kaynak listesi ile kullanılabilecekse her programı bu listeye eklemek gerek bence.

« Yanıtla #37 : »
Birkaç programın daha kaynaklarını yazayım, işe yarayabilir:

Kod: [Seç]
# Gnome-do
deb http://ppa.launchpad.net/do-core/ubuntu hardy main
deb-src http://ppa.launchpad.net/do-core/ubuntu hardy main

Kod: [Seç]
# Freemind
deb http://eric.lavar.de/comp/linux/debian/ unstable/
deb http://eric.lavar.de/comp/linux/debian/ ubuntu/

Kod: [Seç]
# Conduit
deb http://ppa.launchpad.net/conduit/ubuntu hardy main

Kod: [Seç]
# Official Compiz Fusion PPA repository
deb http://ppa.launchpad.net/compiz/ubuntu hardy main

Kod: [Seç]
# Some Synaptic updates, etc.
deb http://ppa.launchpad.net/mvo/ubuntu hardy main

Kod: [Seç]
# Banshee
deb http://ppa.launchpad.net/banshee-team/ubuntu hardy main
deb-src http://ppa.launchpad.net/banshee-team/ubuntu hardy main

Kod: [Seç]
# Ubuntu Tweak
deb http://ppa.launchpad.net/tualatrix/ubuntu hardy main

Kod: [Seç]
# Deluge-torrent
deb http://ppa.launchpad.net/zachtib/ubuntu hardy main universe

Kod: [Seç]
# Tasque
deb http://ppa.launchpad.net/tasque-packagers/ubuntu hardy main
deb-src http://ppa.launchpad.net/tasque-packagers/ubuntu hardy main

Kod: [Seç]
# Amarok
deb http://ppa.launchpad.net/project-neon/ubuntu hardy main

Kod: [Seç]
# Vlc
deb http://ppa.launchpad.net/c-korn/ubuntu hardy main

Wine 'ı eklemek için uçbirimden:
Kod: [Seç]
wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -
Kod: [Seç]
sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/hardy.list -O /etc/apt/sources.list.d/winehq.list
« Son Düzenleme: 17 Eylül 2008 - 00:35:55 Gönderen: hasanyılmaz »

« Yanıtla #38 : »
Ayrıca Ubuntu, Debian tabanlı bir dağıtım olduğundan yazılım kaynakları yapılandırma dosyasına
Kod: [Seç]
# nano /etc/sources.list komutu ile de erişilebilir. Bu aynı zamanda birazda konsol macerası yaşamak için birebirdir.

Unutmadan ekleyelim Nano, Debian'ın konsol tabanlı bir metin düzenleyicisi olup kaydetmek için yapılan değişiklikleri
Kod: [Seç]
ctrl+x yapılarak sorulan soruya E (evet) dememiz yeterlidir.

Düzeltme yapılarak anlam ve kavram yanlışlığı düzeltilmiştir.
"Bilgi sahibi olmadan fikir sahibi olunmaz." Uğur MUMCU
"Hepimiz özgür yazılımın sendikalı emekçileriyiz." Fadike
http://fadike.org
http://pedalsorler DELL Vostro 5470 i5 4. nesil Ubuntu ön yüklü

« Yanıtla #39 : »
Debian konsol tabanlı derken?
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #40 : »
Arkadaslar bazi guncellemeleri alamiyorum. Yardimci olur musunuz? Tesekkurler. Acemi kullaniciyim. Yeni linux kullanmaya basladim. Sag olun. Alamadigim guncellemeler e2fsprogs ve initscripts. Tesekkurler.
« Son Düzenleme: 30 Ekim 2008 - 10:20:36 Gönderen: ihtiyar Said »

« Yanıtla #41 : »
arkadaslar bazi guncellemeleri alamiyorum. yardimci olurmusunuz tesekkurler. acemi kullaniciyim. yeni linux kullanmaya basladim. sagolun.  alamadadigim guncellemeler e2fsprogs ve initscripts tesekkurler


Bu Hardy'de olan ve Türkçe yerelinden kaynaklanan önemsiz bir hata. Yakında sistem güncellemesi ile yeni versiyon olan Intrepid Ibex'e geçmeyi planlıyorsanız dert etmeyin. Daha fazla bilgi için:
http://forum.ubuntu-tr.net/index.php/topic,948.0.html
« Son Düzenleme: 12 Ocak 2009 - 11:06:58 Gönderen: erginemr »

« Yanıtla #42 : »
Intrepid de yasadigim bazi problemler yuzunden hardy e geri donuyorum ve merak ettim hardy e intrepid depolarini eklersem problem yasarmiyim? Veya gnome 2.24 ve *diğer guncel programlari hardy e nasil kazandirabilirim?

« Yanıtla #43 : »
Intrepid de yasadigim bazi problemler yuzunden hardy e geri donuyorum ve merak ettim hardy e intrepid depolarini eklersem problem yasarmiyim? Veya gnome 2.24 ve *diğer guncel programlari hardy e nasil kazandirabilirim?

Bunu daha önce Edgy - Feisty ikilisiyle denemiş biri olarak, kesinlikle tavsiye etmiyorum. Sistem bütünlüğü alt üst olacaktır.

« Yanıtla #44 : »
Intrepid de yasadigim bazi problemler yuzunden hardy e geri donuyorum ve merak ettim hardy e intrepid depolarini eklersem problem yasarmiyim? Veya gnome 2.24 ve *diğer guncel programlari hardy e nasil kazandirabilirim?

Bunu daha önce Edgy - Feisty ikilisiyle denemiş biri olarak, kesinlikle tavsiye etmiyorum. Sistem bütünlüğü alt üst olacaktır.

Biraz gec kaldin uyari icin.  :D

« Yanıtla #45 : »
İlk zamanlar sorun olmayabilir ancak sistemi tamamen yükseltmezsen melez kalır. Böylece ileride sıkıntı yaşamaya başlarsın ve tam yükseltme kaçınılmaz olur gibi geliyor bana.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #46 : »
İlk zamanlar sorun olmayabilir ancak sistemi tamamen yükseltmezsen melez kalır. Böylece ileride sıkıntı yaşamaya başlarsın ve tam yükseltme kaçınılmaz olur gibi geliyor bana.

Benim ilk zamanlarim bile olamdi direk sorun vermeye basladi. 

« Yanıtla #47 : »
Anlattıklarınızı uyguladım. Ama hala audacious ve amarok synaptic paket yöneticimde yok. Ne yapmalıyım?

« Yanıtla #48 : »
http://packages.ubuntu.com/intrepid/audacious
http://packages.ubuntu.com/intrepid/amarok

İkisi de depolarda mevcut. Ayarları doğru yaptığına emin misin? Arama yapmadan önce depolarını güncelledin mi?
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #49 : »
Vermiş olduğunuz Almanya yansılarını ekledim. Depoları nasıl güncelleyebilirim? Kusura bakmayın acemiyim.