Gönderen Konu: [Nasıl]KDE be shell kurulumu  (Okunma sayısı 4254 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« : »
Kde görsel olarak gelişmiş bir masaüstü.Kde için özel bir kabuk olan be shell yükleyerek daha görsel hale getirilebilir.Be shell kurmak için
Kod: [Seç]
git clone git://git.code.sf.net/p/be-shell/code be-shell
cd be-shell
./configure
cd build
make
sudo make install
kodlarını sırasıyla girin.Be shell yüklenmiş olacak.
Kod: [Seç]
kquitapp plasma-desktop
kquitapp kuiserver
kquitapp krunner
kodlarını girip kde servislerini durdumalısınız.
be shell ' i başlatmak için
Kod: [Seç]
be.shell kodunu girmelisiniz.
Kod: [Seç]
kcmshell4 kded kodunu uçbirime'e girip Durum Bildirim Yöneticisi'ni kapatmalısınız.Be shell'i başlatmadan önce dolphin ve tarayıcı gibi şeylerin açık olması tavsiye edilir zira be shell ilk başladığında boş bir ekran geliyor.Bu yüzden önce tema indirilmeli.Temalar'ın yükleniş şekli farklılık gösterebilir.Ama mantık olarak hemen hemen hepsi aynı gibidir.Nasıl yükleneceğini indirdiğiniz temanın README dosyasına bakarak anlayabilirsiniz.Be shell otomatik başlasın istiyorsanız ev dizini/.kde4/share klasörü için autostart isimli bir klasör oluşturun.Klasörün içine ev dizindeki be shell klasörünün içinden beshell.desktop,krunner.desktop,plasma-desktop.desktop dosyalarını kopyalayın.
Be shell'den bir görüntü


Be shell için birkaç tema : http://hombremaledicto.deviantart.com/art/Pluto-theme-for-BE-Shell-beta-382322976
                                              http://lagadesk.deviantart.com/art/BE-WhiteSheep-ver-1-1-326752880
                                              http://hombremaledicto.deviantart.com/art/Nouveau-Theme-for-BE-SHELL-kde-beta-release-323186720
« Son Düzenleme: 03 Temmuz 2013 - 21:56:08 Gönderen: Shinsou »

« Yanıtla #1 : »
Merhaba, anlatımınız için teşekkürler.
Otomatik başlaması için gerekenleri vermişsiniz. Aklıma takılan nokta, kde den birkaç servisi kapatıyoruz, peki onları o komutlarla durdurmuş mu oluyoruz yoksa devre dışı bırakmış mı oluyoruz?
Demek istediğim, sizin anlatımınızla kurup, otomatik başlaması için gerekenleri yaptıktan sonra, bilgisayarı yeniden başlattığımızda çakışma olmaz değil mi?

« Yanıtla #2 : »
Kde'ye herhangi bir zararı olmuyor.Bende servisler normal.kcmshell4 ile durum birdirim yöneticisi'ni durdurmayınca birkaç servis gözükmüyor.Durdurduğunuzda gözüküyor.Zarar yerine yarar'ı oluyor.

« Yanıtla #3 : »
Elinize sağlık @Shinsou. Yanına öntanımlı KDE'ye nasıl geçilir de anlatılsa çok daha güzel olumuş:)

« Yanıtla #4 : »
Rica ederim @if. Öntanımlı kde'ye  ev dizini/.kde4/share klasörü içine oluşturduğumuz autostart klasörünü sildiğimizde geçilebilir  :)
« Son Düzenleme: 04 Temmuz 2013 - 21:46:02 Gönderen: Shinsou »

« Yanıtla #5 : »
Eh, ben şurada takıldım;
./configure kısmına geldiğimde şöyle bir hata alıyorum ve devam edemiyorum. Sizin bir fikriniz olacaktır belki. :)

Kod: [Seç]
-- The C compiler identification is unknown
-- The CXX compiler identification is unknown
CMake Error: your C compiler: "CMAKE_C_COMPILER-NOTFOUND" was not found.   Please set CMAKE_C_COMPILER to a valid compiler path or name.
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
-- Looking for Q_WS_X11
CMake Error at /usr/share/cmake/Modules/CMakeCInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Looking for Q_WS_X11 - not found
-- Looking for Q_WS_WIN
CMake Error at /usr/share/cmake/Modules/CMakeCInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
CMake Error at /usr/share/cmake/Modules/CMakeCInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
CMake Error at /usr/share/cmake/Modules/CMakeCInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Looking for Q_WS_MAC - not found
-- Found Qt-Version 4.8.4 (using /usr/bin/qmake-qt4)
-- Looking for include file pthread.h
CMake Error at /usr/share/cmake/Modules/CMakeCInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Looking for include file pthread.h - not found
-- Could NOT find Threads (missing:  Threads_FOUND)
-- Found OpenSSL: /usr/lib64/libssl.so;/usr/lib64/libcrypto.so (found version "1.0.1e")
-- Looking for _POSIX_TIMERS
CMake Error at /usr/share/cmake/Modules/CMakeCInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
-- Looking for _POSIX_TIMERS - not found
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Did not find automoc4 (Automoc4Config.cmake, install
  git://anongit.kde.org/automoc).  (missing: AUTOMOC4_EXECUTABLE)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/kde4/apps/cmake/modules/FindAutomoc4.cmake:49 (find_package_handle_standard_args)
  /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:423 (find_package)
  /usr/share/cmake/Modules/FindKDE4.cmake:95 (find_package)
  CMakeLists.txt:4 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
Configuration failed :-(

Tabi Ubuntu kullanmadığım için cevap verip vermemek size kalmış.

« Yanıtla #6 : »
Hızlıca sorayım build-essential kurulu mu? Gerçi o sağlıyor mu bilmiyorum, bakamıyorum şu an.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #7 : »
Hızlıca sorayım build-essential kurulu mu? Gerçi o sağlıyor mu bilmiyorum, bakamıyorum şu an.
Öyle bir paket yok diyeyim.

« Yanıtla #8 : »
@Eludecraft, gcc ve gcc-c++ kurulu mu?

« Yanıtla #9 : »
@Eludecraft, kullanıcı adının altında yazdığı şekilde Fedora kullanıyorsun sanırım? Ben öneriyi Ubuntu için yapmıştım, görmemişim o bilgiyi. Gerçi oraya da güvenemiyoruz biz, kullanıcılardan istiyoruz genelde dağıtım bilgisini :)

@if'in söylediği paketlere bakabilirsin.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #10 : »
Evet, dağıtımım Fedora. Bu foruma karşı çok büyük bir saygım oldu, farklı dağıtımdan olsa da yardımınızı eksik etmiyorsunuz. Çok teşekkürler, gcc ve gcc-c++ paketlerini kurarak hallettim. :)

« Yanıtla #11 : »
Farklı dağıtımlar olsa da hepsi GNU/Linux değil mi. Bildiğimiz kadar yardımcı oluruz elbet:)

« Yanıtla #12 : »
centos 5.5 yardımcı olabilirim

« Yanıtla #13 : »
1. Arkadaş hallettim demiş zaten.
2. Yardımcı olabilirim demek yerine doğrudan yardımın kendisini aktarabilirsin buraya.
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #14 : »
/be-shell > ./configure

Kod: [Seç]
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
X11_Xcomposite_LIB (ADVANCED)
    linked by target "be.shell" in directory /home/pars/be-shell

-- Configuring incomplete, errors occurred!
Configuration failed :-(
pars@HEISENBERG:~/be-shell > cd build
pars@HEISENBERG:~/be-shell/build > make
make: *** Hedef belirtilmemiş ve makefile dosyası bulunamadı. Durdu.
[2]pars@HEISENBERG:~/be-shell/build > sudo make install
sudo: /etc/sudoers.d is world writable
make: *** Hedef `install' i derlemek için  hiçbir kural yok. Durdu.
[2]pars@HEISENBERG:~/be-shell/build >

kurulum gerçekleşmedi

« Yanıtla #15 : »
@pars bilisim, libxcomposite-dev paketini kurduktan sonra deneyin.

« Yanıtla #16 : »
Merhabalar birazcık hort atıyorum bespin yükledim çalıştırdım ancak açılan pencereler tam ekran olmuyor yani bespin teması daima üste kalıyor
« Son Düzenleme: 22 Şubat 2014 - 17:29:35 Gönderen: pars bilisim »

« Yanıtla #17 : »
Sağlanamayan bağımlılık nedir?

« Yanıtla #18 : »
hocam onu synaptic paket yöneticisinden hallettim  ancak açılan pencereler tam ekran olmuyor yani bespin teması daima üste kalıyor

« Yanıtla #19 : »
Anladığım kadarıyla Be::Shell virtualbox gibi mevcut KDE oturumunun içinde çalışıyor. Eğer başlangıçta başlamasını istiyorsanız
Alıntı
Be shell otomatik başlasın istiyorsanız ev dizini/.kde4/share klasörü için autostart isimli bir klasör oluşturun.Klasörün içine ev dizindeki be shell klasörünün içinden beshell.desktop,krunner.desktop,plasma-desktop.desktop dosyalarını kopyalayın.

« Yanıtla #20 : »
BE::Shell başlangıçta çalışıyor aynen dediğiniz gibi VB içinde çalışıyormuş gibi KDE içinde çalışıyor. Be shell sonlandırınca düzeliyor .Aslında 2 sıkıntım var 1.si BE SHELL kabugunda masaüstü bölümüne program kısayol v.s atamıyorum 2.side uygulamaların tam ekran sorunu

« Yanıtla #21 : »
arkadaşlar be-shell i kurmaya çalışırken ./configure komutunda aşağıdaki hatayı alıyorum sorun için internette uzun bir araştırma yaptım bir sürü kod deneyip paketler yükledim ama nafile değişen bir şey olmadı sorunun kaynağı ne olabilir sizce sistemim kubuntu 15.04 kde plasma 5.2 ( sorunu libxrender-dev paketini yükleyerek giderdim)

Kod: [Seç]
serdar@serdar-Lenovo-G500:~$ git clone git://git.code.sf.net/p/be-shell/code be-shell
'be-shell' dizinine çoğaltılıyor...
remote: Counting objects: 1689, done.
remote: Compressing objects: 100% (1685/1685), done.
remote: Total 1689 (delta 1088), reused 0 (delta 0)
Nesneler alınıyor: 100% (1689/1689), 1.63 MiB | 449.00 KiB/s, done.
Farklar çözülüyor: 100% (1088/1088), done.
Checking connectivity... tamamlandı.
serdar@serdar-Lenovo-G500:~$ cd be-shell
serdar@serdar-Lenovo-G500:~/be-shell$ ./configure
Configuring... please wait
-- The C compiler identification is GNU 4.9.2
-- The CXX compiler identification is GNU 4.9.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt-Version 4.8.6 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libXau.so;/usr/lib/x86_64-linux-gnu/libXdmcp.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libXau.so;/usr/lib/x86_64-linux-gnu/libXdmcp.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl (found version "5.20.2")
-- Found Phonon: /usr/include (Required is at least version "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.12 include dir: /usr/include
-- Found KDE 4.12 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
X11_Xrender_LIB (ADVANCED)
    linked by target "be.shell" in directory /home/serdar/be-shell

-- Configuring incomplete, errors occurred!
See also "/home/serdar/be-shell/build/CMakeFiles/CMakeOutput.log".
See also "/home/serdar/be-shell/build/CMakeFiles/CMakeError.log".
Configuration failed :-(
serdar@serdar-Lenovo-G500:~/be-shell$
« Son Düzenleme: 07 Haziran 2015 - 12:12:18 Gönderen: Ketboga »
Hiçbir canlı kendisinden daha yüce bir varlığa inanç duymadan ve itaat etmeden yaşamını sürdüremez. İnanç duyanlar bu yükten kurtulmak adına kendilerinden daha güçlü kişileri ararlar ve buna karşılık, bunu aradıkları o kişiler de inanç duyabilecekleri daha da güçlü kişileri ararlar. Ve İşte krallar böyle doğar… Ve işte Tanrılar böyle doğar.

« Yanıtla #22 : »
libxrender-dev ve libx11-dev paketlerini kurun.