Gönderen Konu: KDE - Taşınabilir bellek ve cdlerde Türkçe karakter sorunu.  (Okunma sayısı 2161 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Merhaba;
Şu an sistemimde Kubuntu 8.04 kurulu. Klasör ve dosya isimlerinde Türkçe karakterlerde hiçbir sorun yok fakat taşınabilir bellek , taşınabilir HDD, cd ve dvdlerde dosya isimlerinde ve klasör isimlerinde Türkçe karakterler düzgün görünmüyor. Bu da kopyalama yaparken veya dosyayı çalıştırırken KDE'nin hata vermesine sebep oluyor. Aynı sorun samba ile windows makinelerine bağlanınca da oluyor. Sonuç olarak sisteme sonradan bağlanan ortamlarda Türkçe karakter problemi yaşanıyor.  Bu konuda yardımlarınızı bekliyorum.
« Son Düzenleme: 14 Haziran 2008 - 17:40:39 Gönderen: egitimist »

« Yanıtla #1 : »
Hoşgeldiniz. Öncelikle KDE kontrol merkezi/sistem denetimlerinde bölgesel ve erişilebilirlik içinden ülke olarak Türkiye seçtiğinizden emin olun. Sistemi Türkçe kullanıyorsanız gerekli Türkçe paketlerini de yüklemeniz gerekir. Ayırca konqueror (dosya yöneticisi) içinden ayarlar--konquerorı ayarla kısmından yazı tiplerine girip buradan en altta yer alan kodlama seçeneğini de "dil kodlamasını kullan", "utf8" ya da "iso-8859-9" şeklinde değiştirerek deneyin.

Sabit aygıtlar ve CD/DVD sürücüler sistemdeki /etc/fstab dosyasında belirtildiği şekilde bağlanır. Bu nedenle CD/DVD fstab girişlerini size vereyim, eğer farklılık varsa ona göre düzenleme yapın:

Kod: [Seç]
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto,exec,utf8 0       0

Bunlar benim DVDROM ve DVDwriter girişlerim. Sizinkiler /dev/sdc ya da /dev/sdb olabilir. Burada önemli olan utf8 kodlamasıdır. Bu parametrenin eklendiğinden emin olun. alt+F2 çalıştırma kutusuna:

Kod: [Seç]
kdesu kate /etc/fstab yazarak dosyayı açın ve eksiklik var ise düzenleyin.

« Yanıtla #2 : »
Dediklerinizi yaptım sistemimde kde Türkçe dil paketi de yüklü. Ben kde4 kullanıyorum. Dosya yöneticisi olarak dolphin var. Ayrıca ilginç birşeyi daha farkettim. Taşınabilir belleğin eski içinde kayıtlı dosyalarda Türkçe karakterler görünmezken yeni bir dosya oluşturduğumda Türkçe karakterle düzgün görünüyor.  fstab dosyamın örneği de;

Kod: [Seç]
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=b61d112d-ebdc-476d-9fff-a34402804a26 /               ext3  relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=09469864-8e7e-44f2-99e4-56637c2a630e none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

şeklinde
« Son Düzenleme: 14 Haziran 2008 - 17:43:45 Gönderen: egitimist »

« Yanıtla #3 : »
Taşınabilir bellekler ve artık diğer sabit disk bölümleri (kök dizini dışındakiler) Ubuntu'da udev ile bağlanıyor, yani öntanımlı olarak fstab içinde taşınabilir bellek girişi yok, gördüğünüz gibi. Fakat siz ekleyebilirsiniz. Diğer başlıkta da belirttiğim gibi /etc/default/locale içeriğinde utf8 kodlamasıyla birlikte dil seçildiğinden emin olun.

Şu başlıkta anlatım var: http://forum.ubuntu-tr.net/index.php?topic=1733.msg17681#msg17681

Gelelim fstaba. Eğer isterseniz, udev yerine direk fstab girişi ekleyebilirsiniz. İlk etapta ntfs-config pakedini kurarak, dahili ve harici diskler için yazma ve okuma desteğini etkinleştirerek fstaba eklenmesini sağlayabilirsiniz. Daha sonra sorun olursa elle düzenleyip, "utf8" ya da "iso8859" parametresini ekleyebilirsiniz. Komut ile eklemek için:

http://forum.ubuntu-tr.net/index.php?topic=1281.msg11807#msg11807
« Son Düzenleme: 12 Ocak 2009 - 19:55:54 Gönderen: foma »