Gönderen Konu: [Nasil] PulseAudio Kullanarak Surround Ses kullanimi  (Okunma sayısı 17432 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

« Yanıtla #1 : »
Evet arkadaslar 5+1, 6+1, 7+1,  8+1 gibi Ses sistemleri tam bir sekilde kullanmak icin neler yapilmasi gerekiyor onlari anlatacagim.
Degisiklik yapacagimiz dosya PulseAudio nun daemon.conf dosyasinda degisiklik yapacagiz. Bu dosya icergini incelerseniz ses sisteminin nasil calisacagini gösteren kisa komutlar bulunmaktadir. Bazilarinin ne oldugunu bende bilmiyorum :) zaten bilmenizde gerekmiyor. Biz ses kartimizin coklu hoparlör sistemlerinin aktif olmasini ögrenecez. Islemlere baslamadan önce söyle bir öneri yapayim. Bass ve Tiz kalitesi olan bir muzigi bir kac kere dinleyin ve kulak aliskanligini yapin. Ardindan yapacagimiz degisiklikler ayni muzikte ne kadar fark yapti bakin. Bu sekilde degisiklikler istediginiz sekilde olup olmadigina karar verirsiniz. Islemlere baslamadan öncede dosyamizin yedegini olusturalim. Begenmezsek tek bir komutla geri alabiliriz. yedek icin
Kod: [Seç]
sudo cp /etc/pulse/daemon.conf /etc/pulse/daemon.conf_yedek Asagidaki komutla dosyamizi acalim.

Kod: [Seç]
sudo gedit /etc/pulse/daemon.conf Dosyamizi actiktan sonra Surround icin gerekli olan dosyamizi buluyoruz. Dosyamiz 73. Satirda bulunuyor
Kod: [Seç]
default-sample-channels = 2 Standart degeri 2. Bu deger Kanal kullanimlarini belirtiyor. 5+1 Sistem kullanacaklar 2 yi silip oraya 6 yazacaklar. Kisaca kullandiginiz ses sisteminin Subwoofer le beraber kullanilacak hoparlörlerin toplamini yazacaksiniz. Örnegin bende 6+1 Set var ben degeri 7 yaptim.  Bir diger önemli konu Subwoofer icin. Ubuntu 9.4 ile beraber dosyanin icindeki su satir silinmesi gerekiyor "disable-lfe-remixing = no " bu satir Subwooferun tam bir sekilde calismasi icin gerekli. Kisa bir not düseyim buraya. Bu satir aslinda var ve "yes" olarak isaretlenmis. Ben yinede sildim. Subwoofer de degisiklik varmi, evet var. Bu kisiden kiseye degisebilir. Sizde Subwoofer istediginiz sekilde calisiyorsa bu satirda degisiklik yapmaniza gerek yok. Diger önemli bir konu sesin kalitesini arttirmak icin 50 ve 51. satirlara ekleyin.
Kod: [Seç]
resample-method = src-sinc-best-quality ve
Kod: [Seç]
resample-method = speex-float-1 Buradaki 1 degerini bazi yerlerde "10"  seklinde kullananlar var. Yani kendi kulaginiza göre burayida degistirebilirsiniz. :) PulseAudio durdurup yeniden baslatiyoruz.
Kullanici adimizi pulse, pulse-acces, pulse-rt grublarina ekliyoruz. ve alt+f2 ile kombinasyonunu kullanarak acilan pencereye
Kod: [Seç]
polkit-gnome-authorization giriyoruz. Acilan pencereden PulseAudio altinda bulunan real-time ve High.Priority secenenklerine tiklayarak kullanici adimizi ekliyoruz. Aslinda burasi tehlikeli bir yer dikkat ediniz.
Kod: [Seç]
pulseaudio -k    -> Sonlandir PulseAudio
Kod: [Seç]
pulseaudio -D    -> Yeniden baslat daemon

Ve test edebilirsiniz. Subwoofer testleri icin youtube de "bass test" olarak arama yapin ilgili bir tane bas video sunu acip bass kontrolu yapabilirsiniz.
Yine dosyamizda ses kalitesindeki ilginc karisikliklar, cizirti filan icin
 
Kod: [Seç]
default-fragments = 8
default-fragment-size-msec = 10
bu iki satirdaki degerlerle oynayarak düzgün ayarlamayi yapabilirsiniz. Ön tanimli degerler 8 ve 10 bu degerler ses kartindan ses kartina farklilik oldugu icin ayarlamayi kendiniz yapmaniz gerekiyor.

Medya oynaticilari arasinda karisiklik yada biri calarken digeri calmiyorsa bir karisiklik varsa, var olan asagidaki kodlari ilgili dosyamizda degistiriyoruz.
Kod: [Seç]
high-priority = yes
nice-level = -20

Ubuntu 9.04 te  bu dosyayi root olarak degistiriyoruz /etc/security/limits.conf dosyanin en altina asagidaki satirlari ekliyoruz.
Kod: [Seç]
@audio          -       nice            -20
@pulse-rt       -       nice            -20
Kaynak: http://wiki.ubuntuusers.de/PulseAudio
« Son Düzenleme: 06 Temmuz 2009 - 14:34:59 Gönderen: Kirmizi »
Linux LPIC1 - MCSA

« Yanıtla #25 : »
ses kartım creative audigy (audigy1. nesil), creative 5.1 speakerlarım var. windowsta sorunsuz çalışıyorlar. ama linuxta bazı speakerlar çalışmıyor ve subwoofer çalışmıyor.
ubuntu 10.10 kullanıyorum
burda yazdığı gibi  komut satırına

 gksu gedit /etc/pulse/daemon.conf

yazdım

; default-sample-channels = 2

bu satırı

default-sample-channels = 6
şeklinde yazıp noktalı virgülü kaldırdım kaydettim bilgisayarı yenişden başlattım.
terminale yazdım

speaker-test -Dplug:surround51 -c6 -l1 -twav

yazdım ve
battal@cagatay:~$ speaker-test -Dplug:surround51 -c6 -l1 -twav

speaker-test 1.0.23

Oynatım aygıtı plug:surround51
Akım değiştirgeleri 48000Hz, S16_LE, 6 kanal
WAV dosya(ları)
Hız 48000Hz'e ayarlandı (istenen 48000Hz)
Arabellek boyutu 64 - 16384 arası
Dönem boyutu 16 - 16384 arası
Maksimum ara bellek boyutu kullanılıyor 16384
Dönemler = 4
ayarlanan period_size = 4096
ayarlanan buffer_size = 16384
 0 - Ön Sol
 4 - Merkez
 1 - Ön Sağ
 3 - Arka Sağ
 2 - Arka Sol
 5 - LFE
8,370351 başına zaman dilimi
battal@cagatay:~$
ve merkezden hiç ses gelmiyor
ön sağ aşırı boguk
LFE (subwooferdan hiç ses gelmiyor)

ses tercihlerinden analog surround 5.1 output/ analog input seçili mute değil
sorunu nasıl çözebilirim.

« Yanıtla #26 : »
Kullandığın speaker test komutunda kolonlardan sağlıklı ses alabildin mi? Medya oynatıcılarda aynı sorunu yaşıyor musun; örneğin herhangi bir film oynatıcıda 5+1 sesi ağlıklı alabiliyor musun yoksa sorun sadece sistem seslerinde mi?
Özgürlüğü ne kadar anlarsan o kadar az sahip olursun. John Fowles

« Yanıtla #27 : »
film oynatıcı , vlc, gmplayer da aynı sorun var. hala ugraşıyorum

« Yanıtla #28 : »
Alıntı
Kullandığın speaker test komutunda kolonlardan sağlıklı ses alabildin mi?

Sistemimdeki ses kartı Creative Audigy Live! 24 bit ve 10.10 64 bit üzerinde sorunsuz 5+1 ses alabiliyorum.  Ubuntu'yu ilk kurduğun zamandan beri mi yaşıyorsun bu sorunu?
Özgürlüğü ne kadar anlarsan o kadar az sahip olursun. John Fowles

« Yanıtla #29 : »
İyi günler.

Öncelikle şunu söyleyeyim ki Ubuntu'da çok yeniyim. Yabancı bir arkadaşımın tavsiyesi üzerine kullanmaya başladım, genelde bir sıkıntım olduğunda bana yardımcı oluyor ama bu konuyu bir türlü çözemedik. Bende 2+1 var ve merkezden ses alamıyorum.

Kullandığım sürüm 10.10. "default-sample-channels = 2", buradaki 2'yi de 3 ile değiştirdim. Bu satır bende 73'te değil, 78'deydi. Bende "disable-lfe-remixing = no" diye bir satır yok, o yüzden bir şey de silmedim. Değişikliği yapmama rağmen 2 küçük kolondan ses alırken merkezden bir türlü ses alamıyorum, Windows'ta ise bu çalışıyor.

« Yanıtla #30 : »
alsa,pulse,oss üçünüde denedim 10,10 da 5+1 veremedim denemediğim yöntem kalmadı çip relatek hd880 orjinal sürücülerinde ve sitesinde alsa derlemeler mevcut 10,10 da çalısmıyor alsada testte 5,1 çalısıyor ama icraata gelice bişe yok sırf denemek için  5+1 surrount waw yaptım nero sound track da kanalları tek tek gezdirdim  xpde  harika ama ubuntuda yine 2 kanalı geçmiyor 10,10 dan kaynaklanan bir sorunmu acaba

« Yanıtla #31 : »
10.04 sürümünden bu yana, yani 2 sürümdür.) ses sorunları yaşamıyorum. (Cereative, realtek, Via denenen ses işlemcileri arasında, tabi her model değil.) Hem genel forumlarda hem bizim forumda 5+1 ses ile ilgili son zamanlanlada pek konu açılmıyor. Demem o ki büyük ihtimalle ses yapılandırmasındaki bir eksiklik bu soruna neden olabilir. Farklı seçenekleri yoklamakta fayda var. Örneğin yönetim/tercihler>ses uygulamasıyla farklı hopörler ayarları denenebilir. Veyahut alsamixer ile açık-kapalı kanallar kontrol edilebilir.

Bu uğraşlara rağmen 5+1 ses elde edilemiyorsa soruna dair bir başlık açıp hangi yöntemlerin denendiği özetlendikten sonra şu çıktıları iletiye eklemek işleri kolaylaştırır.

Kod: [Seç]
lspci
lspci | grep -i audio
aplay -l
Özgürlüğü ne kadar anlarsan o kadar az sahip olursun. John Fowles

« Yanıtla #32 : »
forumda ki bütün anlatımlar 10,04 dü geçmemiş sırf inat uğruna bütün yöntemleri denedim anlatılan tüm yöntemleri 10,10 da var sanırım bu sorun

« Yanıtla #33 : »
Bu satrı sayıları dosyadan dosyaya farklılık gösteriyormu? Mesela bendeki 73. satırda 'rlimit-rttime = 1000000' yazıyor 77. satırda ise 'default-sample-channels = 2' yazıyor. Şimdi yukardaki anlatıma göre 73. satırı mı değiştirmeliyim yoksa 77. satırı mı? Birde bu pulseaudioyu durdurup yeniden başlatmak nasıl oluyor? Heartmagic de anlatmış ama anlamadım :(

« Yanıtla #34 : »
Satırlar değişmişse ve yerleri belli değilse açıkçası nasıl belirlenir şu an bilemiyorum. Ekleme çıkartmayla deneme yapılabilir. Pulseaudio'yu yeniden başlatmak için:
Kod: [Seç]
sudo pulseaudio -kOlmazsa:
Kod: [Seç]
sudo killall pulseaudio
Hayattan çıkarı olmayanların, ölümden de çıkarı olmayacaktır.
Hayatlarıyla yanlış olanların ölümleriyle doğru olmalarına imkân var mıdır?

Böylece yalan, dünyanın düzenine dönüştürülüyor.

« Yanıtla #35 : »
Anlatımdaki basamakları 'polkit-gnome-authorizatio' komutuna kadar yaptım. Bu komuta geldiğimde alt f2 ile açılan pencereye bu komutu yazdığımda' polkit-gnome-authorization konumu açılamadı böyle bir dosya veya dizin yok hatası alıyorum. Bir diğer problemim de pulse audio yu  'pulseaudio -D' komutu ile başlatamıyorum başına sudo eklememe rağmen yeniden başlatamadım.
« Son Düzenleme: 20 Nisan 2011 - 22:11:34 Gönderen: acer »

« Yanıtla #36 : »
Arkadaslar konu güncellenmesi gerekiyor.  Benimde zamanim  olmadigi icin güncelleme olmadi. Bu yüzden bazi komutlar calismayabilir.  Örnegin suanda ön sag, sol+arka sag, sol calisiyor Subwoofer+ön+arka  calismiyor. Bunun disinda
Kod: [Seç]
/etc/pulse/daemon.conf burada degisikliklerin kullanilabilmesi icin kodlarin basinda bulunan ; kaldirilmasi gerekiyor. Konuyu ilk hazirladigimda Anakartin onboard ses kartini kullaniyordum. Ses karti cikisi 6 oldugu icin Hoparlör setini tam olarak kullaniyordum.  SImdik Creative X-Fi Titanium PCIE kullaniyorum. Bunda sorun var. Sanirim kart emulasyon üzerinden destekleniyor. Belki bu yüzden de belli bölümleri standart ayarlada calismiyor olabilir. Simdilik bu konuda yorum yapmak cok erken. Birseyler bulursam tekrar konuyu güncellerim.
Linux LPIC1 - MCSA

« Yanıtla #37 : »
Güncellenmesi gereken bu başlık acaba nezaman güncellenir ve nezaman wiki belgesi olur (wikiye eklenir)? Arkadaşlar ubuntu yazılım merkezinden pulse diye arattığımda 'pulseaudio ses kontrolü, pulse audio aygıt seçici, pulseaudio yöneticisi ve birde pulseaudio tercihleri' gibi programalr çıkıyor. Acaba ben bu programları kursam 5+1 ses sistemimi oluşturabiilr miyim?

« Yanıtla #38 : »
Depodan pavumeter paketini kurup pavucontrol uygulaması ile ayarlayabilirsiniz.

« Yanıtla #39 : »
localhost arkadaşın dediği gibi bazı kartlar emilasyon üzerinden 5+1 desteği sunuyor ondan ubuntuda 5+1 ses alamıyoruz sanırım

« Yanıtla #40 : »
Analog çıkıştan 2+1 hoparlör ve S/PDIF çıkışından 5+1 surround kulaklık kullanıyorum.
Burada yazan düzenlemeleri yaparsam sadece birini kullanmak zorunda kalıyorum.
"Analog Stereo Output, Digital Stereo Duplex" gibi default profiller yerine kendi profillerimizi oluşturabilir miyiz?

« Yanıtla #41 : »
Lİnux'un herhangi bir sürümünde surround ses elde edebilen var mı cidden ? 6 hoparlörden ses elde etmek değil kastım.
Mint-Ubuntu-Mageia-Pardus-Arch

Özgürlük için LİNUX !

« Son Düzenleme: 05 Eylül 2011 - 00:38:25 Gönderen: hayspat »